summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_installdeb11
2 files changed, 9 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index d99c651f..d17cad1b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ debhelper (7.3.10) UNRELEASED; urgency=low
when Build does not exist (ie due to being run twice in a row).
Closes: #539848
* dh_builddeb: Fix man page typo. Closes: #539976
+ * dh_installdeb: In udeb mode, support the menutest and isinstallable
+ maintainer scripts. Closes: #540079 Thanks, Colin Watson.
-- Joey Hess <joeyh@debian.org> Tue, 04 Aug 2009 13:19:31 -0400
diff --git a/dh_installdeb b/dh_installdeb
index fdc76e60..93198ae5 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -54,10 +54,13 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (is_udeb($package)) {
# For udebs, only do the postinst, and no #DEBHELPER#.
- my $f=pkgfile($package,"postinst");
- if ($f) {
- doit("install", "-o", 0, "-g", 0, "-m", 755,
- $f, "$tmp/DEBIAN/postinst");
+ # Udebs also support menutest and isinstallable scripts.
+ foreach my $script (qw{postinst menutest isinstallable}) {
+ my $f=pkgfile($package,$script);
+ if ($f) {
+ doit("install", "-o", 0, "-g", 0, "-m", 755,
+ $f, "$tmp/DEBIAN/$script");
+ }
}
next;
}