summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdh_installinit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e367c15c..a93c8b93 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
debhelper (9.20140229) UNRELEASED; urgency=medium
* Minor typos. Closes: #741144, #744176
+ * dh_installinit: Fix uninitialized value warning when --name is used.
-- Joey Hess <joeyh@debian.org> Mon, 10 Mar 2014 12:39:21 -0400
diff --git a/dh_installinit b/dh_installinit
index 1926e9fa..0944d306 100755
--- a/dh_installinit
+++ b/dh_installinit
@@ -165,7 +165,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $scriptsrc;
my $jobfile=$package;
if (defined $dh{NAME}) {
- $jobfile=$script=$dh{NAME};
+ $jobfile=$script=$scriptsrc=$dh{NAME};
}
elsif ($dh{D_FLAG}) {
# -d on the command line sets D_FLAG. We will