summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules25
3 files changed, 19 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index cbd88929..29b06534 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.0.1) unstable; urgency=low
+
+ * Build-depends on perl-5.6, since it uses 2 argument pod2man.
+ * Cleanups of debhelper.1 creation process.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 12 Feb 2001 16:12:59 -0800
+
debhelper (3.0.0) unstable; urgency=low
* Added dh_installman, a new program that replaces dh_installmanpages.
diff --git a/debian/control b/debian/control
index ddafecfb..7a9bb7ad 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: debhelper
Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
-Build-Depends-Indep: perl-5.005, fileutils (>= 4.0-2.1), file (>= 3.23-1)
+Build-Depends-Indep: perl-5.6, fileutils (>= 4.0-2.1), file (>= 3.23-1)
Standards-Version: 3.5.0.0
Package: debhelper
diff --git a/debian/rules b/debian/rules
index f889fee5..a746144a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,13 +25,9 @@ VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Ver
build: test build-stamp
build-stamp:
- # Turn all executables and .pod files into man pages.
- find . \( \( -type f -perm +1 -maxdepth 1 \) -or \
- \( -type f -name '*.pod' \) \) \
- -exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
- mv -f debhelper.pod.1 debhelper.1
- # Fix up the debhelper.1 man page, substituting in a list of all
- # debhelper commands. Eek!
+ # Generate the main man page. All the perl cruft is to get a list
+ # of debhelper commands with short descriptions into the man page.
+ pod2man -c Debhelper -r "$(VERSION)" debhelper.pod | \
perl -e ' \
undef $$/; \
foreach (@ARGV) { \
@@ -43,13 +39,14 @@ build-stamp:
} \
} \
END { \
- open(IN,"debhelper.1") or die "debhelper.1: $$!"; \
- $$file=<IN>; \
- open(OUT,">debhelper.1") or die "debhelper.1: $$!";; \
- $$file=~s/#LIST#/$$collect/; \
- print OUT $$file; \
- close OUT; \
- }' dh_*
+ while (<STDIN>) { \
+ s/#LIST#/$$collect/; \
+ print; \
+ }; \
+ }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*"` > debhelper.1
+ # Turn all executables into man pages.
+ find . -type f -perm +1 -maxdepth 1 -name "dh_*" \
+ -exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
touch build-stamp
clean: