summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdh_shlibdeps2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6b5b8ea4..bcfb45ce 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ debhelper (6.0.4) UNRELEASED; urgency=low
* dh_strip: Improve the idempotency fix put in for #380314.
* dh_strip: The -k flag didn't work (--keep did). Fix.
+ * dh_shlibdeps: Add emul to exclude list.
-- Joey Hess <joeyh@debian.org> Thu, 24 Jan 2008 21:39:37 -0500
diff --git a/dh_shlibdeps b/dh_shlibdeps
index e705d73b..e859f04a 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -119,7 +119,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
foreach my $file (split(/\n/,`find $tmp -type f \\( -perm +111 -or -name "*.so*" \\) $find_options -print`)) {
# Prune directories that contain separated debug symbols.
- next if $file=~m!^\Q$tmp\E/usr/lib/debug/(lib|lib64|usr|bin|sbin|opt|dev)/!;
+ next if $file=~m!^\Q$tmp\E/usr/lib/debug/(lib|lib64|usr|bin|sbin|opt|dev|emul)/!;
# TODO this is slow, optimize. Ie, file can run once on
# multiple files..
$ff=`file "$file"`;