summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_makeshlibs13
2 files changed, 18 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5d9e2950..f19766b0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.0.29) unstable; urgency=low
+
+ * Added -X flag to dh_makeshlibs, for packages with wacky plugins that
+ look just like shared libs, but are not.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 1 Jun 2001 14:27:06 -0400
+
debhelper (3.0.28) unstable; urgency=low
* dh_clean: clean up temp files used by earlier versons of debhelper.
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 346a5f5a..bb1d8acd 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
- dh_makeshlibs [debhelper options] [-mmajor] [-V[dependancies]] [-n]
+ dh_makeshlibs [debhelper options] [-mmajor] [-V[dependancies]] [-n] [-Xitem]
=head1 DESCRIPTION
@@ -49,6 +49,11 @@ information needed (be sure to include the package name).
Do not modify postinst/postrm scripts.
+=item B<-X>I<item>, B<--exclude=>I<item>
+
+Exclude files that contain "item" anywhere in their filename from
+being treated as shared libraries.
+
=back
=head1 EXAMPLES
@@ -89,7 +94,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# packages. This may have a few false positives, which is ok,
# because only if we can get a library name and a major number from
# objdump is anything actually added.
- open (FIND, "find $tmp -type f -name '*.so*' |");
+ my $exclude='';
+ if (defined($dh{EXCLUDE_FIND}) && $dh{EXCLUDE_FIND} ne '') {
+ $exclude="! \\( $dh{EXCLUDE_FIND} \\) ";
+ }
+ open (FIND, "find $tmp -type f -name '*.so*' $exclude |");
while (<FIND>) {
my ($library, $major);
my $objdump=`objdump -p $_`;