summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_listpackages1
2 files changed, 7 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 9df366f5..a5696ad7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,12 @@ debhelper (7.0.3) unstable; urgency=low
* dh: Fix man page typos. Closes: #477933
* Add missing $! to error message when the log can't be opened.
+ * One problem with the log files is that if dh_clean is not the last command
+ run, they will be left behind. This is a particular problem on build
+ daemons that use real root. Especially if cdbs is used, since it runs
+ dh_listpackages after clean, thereby leaving behind log files that
+ only root can touch. Avoid this particular special case by inhibiting
+ logging by dh_listpackages.
-- Joey Hess <joeyh@debian.org> Tue, 29 Apr 2008 01:40:03 -0400
diff --git a/dh_listpackages b/dh_listpackages
index f919ef62..79b664bd 100755
--- a/dh_listpackages
+++ b/dh_listpackages
@@ -23,6 +23,7 @@ act on if passed the same options.
=cut
init();
+inhibit_log();
print join("\n",@{$dh{DOPACKAGES}})."\n";
=head1 SEE ALSO