summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_auto_configure3
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 05f05085..08ed8266 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.2.13) unstable; urgency=low
+
+ * dh_auto_configure: Pass --skipdeps safely via PERL_AUTOINSTALL.
+ Closes: #528235
+
+ -- Joey Hess <joeyh@debian.org> Thu, 14 May 2009 15:21:21 -0400
+
debhelper (7.2.12) unstable; urgency=low
* dh_auto_configure: Revert --skipdeps change
diff --git a/dh_auto_configure b/dh_auto_configure
index d69ed162..5f48056f 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -91,6 +91,9 @@ elsif (-e "Makefile.PL") {
# If set to a true value then MakeMaker's prompt function will
# always return the default without waiting for user input.
$ENV{PERL_MM_USE_DEFAULT}=1;
+ # This prevents Module::Install from interactive behavior.
+ $ENV{PERL_AUTOINSTALL}="--skipdeps";
+
doit("perl", "Makefile.PL", "INSTALLDIRS=vendor",
"create_packlist=0", @{$dh{U_PARAMS}});
}