summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debian/changelog12
-rwxr-xr-xdh_perl8
3 files changed, 17 insertions, 5 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index f22e8171..7ebbe61b 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -55,7 +55,7 @@ sub init {
my $x=$_;
$x=escape_shell($x);
$x=~s/\./\\\\./g;
- $dh{EXCLUDE_FIND}.="-regex .\\*$x.\\* -or ";
+ $dh{EXCLUDE_FIND}.="-regex .*$x.* -or ";
}
$dh{EXCLUDE_FIND}=~s/ -or $//;
}
diff --git a/debian/changelog b/debian/changelog
index 4abd71ee..74d893bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+debhelper (4.1.6) unstable; urgency=low
+
+ * Clarified dh_perl man page. Closes: #159332
+
+ -- Joey Hess <joeyh@debian.org> Tue, 3 Sep 2002 12:27:08 -0400
+
+debhelper (4.1.5) unstable; urgency=low
+
+ * Fixed excessive escaping around terms in DH_EXCLUDE_FIND. Closes: #159155
+
+ -- Joey Hess <joeyh@debian.org> Sun, 1 Sep 2002 19:20:32 -0400
+
debhelper (4.1.4) unstable; urgency=low
* Patch from Andrew Suffield to make dh_perl understand #!/usr/bin/env perl
diff --git a/dh_perl b/dh_perl
index e9a001d9..29c24c98 100755
--- a/dh_perl
+++ b/dh_perl
@@ -2,7 +2,7 @@
=head1 NAME
-dh_perl - calculates perl scripts & modules dependencies
+dh_perl - calculates perl dependencies
=cut
@@ -21,9 +21,9 @@ dh_perl is a debhelper program that is responsible for generating
the ${perl:Depends} substitutions and adding them to substvars files.
The program will look at perl scripts and modules in your package,
-and will use this information to generate a dependency.
-The dependency will be substituted into your package's control file
-wherever you place the token "${perl:Depends}".
+and will use this information to generate a dependency on perl or
+perlapi. The dependency will be substituted into your package's control
+file wherever you place the token "${perl:Depends}".
=head1 OPTIONS