summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debhelper.pod6
-rw-r--r--debian/changelog7
-rw-r--r--debian/control4
-rwxr-xr-xdh_compress6
4 files changed, 19 insertions, 4 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 08c5115..7cf755c 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -286,6 +286,12 @@ scripts. (This may later be rolled back into V3).
=item -
+You are encouraged to put the new ${misc:Depends} into debian/control to
+suppliment the ${shlibs:Depends} field. In particular, the new
+dh_installinit feature needs a versioned dependency on sysvinit.
+
+=item -
+
dh_fixperms will make all files in bin/ directories and in etc/init.d
executable.
diff --git a/debian/changelog b/debian/changelog
index c4b0239..8b2e729 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.0.11) unstable; urgency=low
+
+ * dh_compress: always compress .pcf files in
+ /usr/X11R6/lib/X11/fonts/{100dpi,75dpi,misc}, as is required by policy.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 1 Jun 2002 18:08:50 -0400
+
debhelper (4.0.10) unstable; urgency=low
* Consistently use the which command instead of command -v or hardcoded
diff --git a/debian/control b/debian/control
index c97b8c6..a20c1c6 100644
--- a/debian/control
+++ b/debian/control
@@ -2,12 +2,12 @@ Source: debhelper
Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
-Build-Depends-Indep: perl (>= 5.6.1), fileutils (>= 4.0-2.1), file (>= 3.23-1), debconf-utils (>= 1.1.1)
+Build-Depends-Indep: perl (>= 5.6.1), fileutils (>= 4.0-2.1), file (>= 3.23-1), debconf-utils (>= 1.1.1), dpkg-dev (>= 1.9.0)
Standards-Version: 3.5.6.1
Package: debhelper
Architecture: all
-Depends: ${perl:Depends}, fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.7.0), html2text, debconf-utils, binutils
+Depends: ${perl:Depends}, ${misc:Depends}, fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.7.0), html2text, debconf-utils, binutils
Suggests: dh-make
Description: helper programs for debian/rules
A collection of programs that can be used in a debian/rules file to
diff --git a/dh_compress b/dh_compress
index 6fc20b1..5e8bb37 100755
--- a/dh_compress
+++ b/dh_compress
@@ -25,7 +25,8 @@ By default, dh_compress compresses files that debian policy mandates should
be compressed, namely all files in usr/share/info, usr/share/man,
usr/X11R6/man, files in usr/share/doc that are larger than 4k in size,
(except the copyright file, .html files, and files that appear to be already
-compressed based on their extensions), and all changelog files.
+compressed based on their extensions), and all changelog files. Plus PCF
+fonts underneath usr/X11R6/lib/X11/fonts/
If a debian/package.compress file exists, however, it will be ran as a shell
script, and all filenames that the shell script outputs will be compressed
@@ -101,7 +102,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
! -iname "*.tgz" ! -iname "*.z" ! -iname "*.bz2" \\
! -iname "*-gz" ! -iname "*-z" ! -iname "*_z" \\
! -iname "*.jar" ! -iname "*.zip" \\
- ! -name "copyright" 2>/dev/null || true
+ ! -name "copyright" 2>/dev/null || true;
+ find usr/X11R6/lib/X11/fonts -type f -name "*.pcf" 2>/dev/null || true;
`);
}