summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules5
-rwxr-xr-xdh_installdebconf2
4 files changed, 9 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index a3dbacf4..c97f464b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,11 @@
debhelper (4.1.38) unstable; urgency=low
-UNRE
* Fixed dh_installcatalog's references to itself on man page.
Closes: #184411
+ * dh_installdebconf: Set umask to sane before running po2debconf or
+ debconf-mergetemplates
- -- Joey Hess <joeyh@debian.org> Thu, 13 Mar 2003 10:51:54 -0500
+ -- Joey Hess <joeyh@debian.org> Sun, 23 Mar 2003 21:17:09 -0800
debhelper (4.1.37) unstable; urgency=low
diff --git a/debian/control b/debian/control
index a699d728..4b4f780c 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl (>= 5.6.1), coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.9.0)
-Standards-Version: 3.5.8.0
+Standards-Version: 3.5.9.0
Package: debhelper
Architecture: all
diff --git a/debian/rules b/debian/rules
index 8d3cf5d5..204cb5a1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -88,9 +88,10 @@ binary-indep: build
# Update the debhelper web page. Not intended for use by anyone except the
# author.
+DIR=/home/web/kitenet.net/programs/debhelper
installhook:
- cp debian/changelog /home/pub/programs/debhelper/CHANGES
- echo -n $(VERSION) > /home/pub/programs/debhelper/LATEST-VERSION-IS
+ cp debian/changelog $(DIR)/CHANGES
+ echo -n $(VERSION) > $(DIR)/LATEST-VERSION-IS
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary dist
diff --git a/dh_installdebconf b/dh_installdebconf
index fc81d1fe..c9c72b2a 100755
--- a/dh_installdebconf
+++ b/dh_installdebconf
@@ -92,6 +92,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Are there old-style translated templates?
my @trans=(glob("$templates.??"), glob("$templates.??_??"));
+ umask(0022); # since I do a redirect below
+
# Look for po directory.
if (-d "debian/po") {
if (@trans) {