summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_compress1
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3a34fc51..f77f35a3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.0.10) UNRELEASED; urgency=low
+
+ * dh_compress: Do not compress index.sgml files, as generated by gtk-doc.
+ Closes: #484772
+
+ -- Joey Hess <joeyh@debian.org> Fri, 06 Jun 2008 11:46:02 -0400
+
debhelper (7.0.9) unstable; urgency=low
* rules.tiny: Typo fix. Closes: #479647
diff --git a/dh_compress b/dh_compress
index 2a996776..575d3bcb 100755
--- a/dh_compress
+++ b/dh_compress
@@ -102,6 +102,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
! -iname "*.tgz" ! -iname "*.z" ! -iname "*.bz2" \\
! -iname "*-gz" ! -iname "*-z" ! -iname "*_z" \\
! -iname "*.jar" ! -iname "*.zip" ! -iname "*.css" \\
+ ! -name "index.sgml" \\
! -name "copyright" 2>/dev/null || true;
find usr/X11R6/lib/X11/fonts usr/share/fonts/X11 -type f -name "*.pcf" 2>/dev/null || true;
`);