summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_shlibdeps2
2 files changed, 3 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index f057c5ae..4892e58d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,7 @@
debhelper (7.2.15) UNRELEASED; urgency=low
- * dh_strip: Also strip OCaml shared libraries. (Stephane Glondu)
- Closes: #527272
+ * dh_strip, dh_shlibdeps: Add support for OCaml shared libraries.
+ (Stephane Glondu) Closes: #527272, #532701
* dh_compress: Avoid compressing .svg and .sgvz files, since these
might be used as images on a html page, and also to avoid needing
to special case the .svgz extention when compressing svg.
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 7b974eb8..3ab89818 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -121,7 +121,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (defined($dh{EXCLUDE_FIND}) && $dh{EXCLUDE_FIND} ne '') {
$find_options="! \\( $dh{EXCLUDE_FIND} \\)";
}
- foreach my $file (split(/\n/,`find $tmp -type f \\( -perm +111 -or -name "*.so*" \\) $find_options -print`)) {
+ foreach my $file (split(/\n/,`find $tmp -type f \\( -perm +111 -or -name "*.so*" -or -name "*.cmxs" \\) $find_options -print`)) {
# Prune directories that contain separated debug symbols.
next if $file=~m!^\Q$tmp\E/usr/lib/debug/(lib|lib64|usr|bin|sbin|opt|dev|emul)/!;
# TODO this is slow, optimize. Ie, file can run once on