summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-xfonts2
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installxfonts4
3 files changed, 10 insertions, 3 deletions
diff --git a/autoscripts/postinst-xfonts b/autoscripts/postinst-xfonts
index 8821bc5f..4c5ab1b8 100644
--- a/autoscripts/postinst-xfonts
+++ b/autoscripts/postinst-xfonts
@@ -1,3 +1,3 @@
if [ -x /usr/sbin/update-fonts-dir ]; then
-#CMDS#
+ #CMDS#
fi
diff --git a/debian/changelog b/debian/changelog
index 2f482b0a..6fb86b43 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.4.5) unstable; urgency=low
+
+ * dh_installxfonts: separate multiple commands with \n so sed doesn't get
+ upset. Closes: #131322
+
+ -- Joey Hess <joey@kitenet.net> Tue, 29 Jan 2002 18:58:58 -0500
+
debhelper (3.4.4) unstable; urgency=low
* Introduced the debian/compat file. This is the new, preferred way to say
diff --git a/dh_installxfonts b/dh_installxfonts
index 51598680..0ee9cb3a 100755
--- a/dh_installxfonts
+++ b/dh_installxfonts
@@ -68,9 +68,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
autoscript($package, "postinst", "postinst-xfonts",
- "s:#CMDS#:".join("\n", map { "\t$_" } @cmds).":;");
+ "s:#CMDS#:".join(";", @cmds).":;");
autoscript($package, "postrm", "postrm-xfonts",
- "s:#CMDS#:".join("\n", @cmds).":;");
+ "s:#CMDS#:".join(";", @cmds).":;");
addsubstvar($package, "misc:Depends", "xutils", ">= 4.0.3");
}