summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/control2
-rwxr-xr-xdh_installman8
-rwxr-xr-xdh_suidregister4
4 files changed, 16 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index b9efd202..7a235fc9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (3.0.6) unstable; urgency=low
+
+ * Corrected some uninitialized value stuff in dh_suidregister (actually
+ quite a bad bug).
+ * dh_installman: fixed variable socoping error, so file conversions
+ should work now.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 16 Feb 2001 14:15:02 -0800
+
debhelper (3.0.5) unstable; urgency=low
* Updated dh_perl to a new version for the new perl organization and
diff --git a/debian/control b/debian/control
index b53ebc73..eaef624d 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl-5.6, fileutils (>= 4.0-2.1), file (>= 3.23-1)
-Standards-Version: 3.5.0.0
+Standards-Version: 3.5.1.0
Package: debhelper
Architecture: all
diff --git a/dh_installman b/dh_installman
index b2a95bae..9c71774f 100755
--- a/dh_installman
+++ b/dh_installman
@@ -61,6 +61,9 @@ interface. Use this program instead.
init();
+my @sofiles;
+my @sodests;
+
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $file=pkgfile($package,"manpages");
@@ -137,8 +140,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
# Now the .so conversion.
- my @sofiles;
- my @sodests;
+ @sofiles=@sodests=();
foreach my $dir (qw{usr/share/man usr/X11R6/man}) {
if (-e "$tmp/$dir") {
find(\&find_so_man, "$tmp/$dir");
@@ -152,8 +154,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
# Check if a file is a .so man page, for use by File::Find.
-my @sofiles;
-my @sodests;
sub find_so_man {
# The -s test is becuase a .so file tends to be small. We don't want
# to open every man page. 1024 is arbitrary.
diff --git a/dh_suidregister b/dh_suidregister
index 19f29b18..64c98b73 100755
--- a/dh_suidregister
+++ b/dh_suidregister
@@ -56,7 +56,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
@files=split(/\n/,`find $tmp -type f -perm +6000`);
# Strip the debian working directory off of the filenames.
- $tostrip="tmp/";
+ $tostrip="$tmp/";
}
else {
# We will strip leading /'s, so the user can feed this
@@ -73,7 +73,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Create the sed string that will be used to
# fill in the blanks in the autoscript files.
# Fill with the owner, group, and perms of the file.
- my (undef,undef,$mode,undef,$uid,$gid,undef) = stat("$tmp/$file");
+ my ($dev,$ino,$mode,$nlink,$uid,$gid,$rdev,$size,$atime,$mtime,$ctime,$blksize,$blocks) = stat("$tmp/$file");
# Now come up with the user and group names for the uid and
# gid.
my $user=getpwuid($uid);