summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdh_install20
-rwxr-xr-xdh_shlibdeps2
4 files changed, 20 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 2549c768..04f72405 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.20) unstable; urgency=low
+
+ * typo in dh_shlibdeps(1), Closes: #167421
+ * dh_movefiles: make --list-missing respect --sourcedir. Closes: #168441
+
+ -- Joey Hess <joeyh@debian.org> Sun, 10 Nov 2002 19:09:00 -0500
+
debhelper (4.1.19) unstable; urgency=low
* Added note to dh_installdebconf(1) about postinst sourcing debconf
diff --git a/debian/control b/debian/control
index 5825a227..28c16b6c 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl (>= 5.6.1), coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.9.0)
-Standards-Version: 3.5.7.0
+Standards-Version: 3.5.7.1
Package: debhelper
Architecture: all
diff --git a/dh_install b/dh_install
index d6f1f1bc..9b03d46a 100755
--- a/dh_install
+++ b/dh_install
@@ -69,9 +69,9 @@ will automatically guess the destination even if this flag is not set.
=item B<--list-missing>
This option makes dh_install keep track of the files it installs, and then at
-the end, compare that list with the files in debian/tmp. If any of the files
-(and symlinks) in debian/tmp were not installed to somewhere, it will
-warn on stderr about that.
+the end, compare that list with the files in the source directory. If any of
+the files (and symlinks) in the source directory were not installed to
+somewhere, it will warn on stderr about that.
This may be useful if you have a large package and want to make sure that
you don't miss installing newly added files in new upstream releases.
@@ -79,10 +79,12 @@ you don't miss installing newly added files in new upstream releases.
Note that files that are excluded from being moved via the -X option are not
warned about.
+You need to use the --sourcedir parameter for this one to be of much use.
+
=item B<--sourcedir=dir>
-Makes all source files be found under dir. If this is specified, it is akin
-to all the source filenames having "dir/" prepended to them.
+Makes all source files be found under dir. If this is specified, it is
+akin to all the source filenames having "dir/" prepended to them.
To make dh_install behave like the old dh_movefiles, move your
package.files file to package.install and call dh_install with
@@ -103,18 +105,18 @@ init();
my @installed;
+my $srcdir = '.';
+$srcdir = $dh{SOURCEDIR}."/" if defined $dh{SOURCEDIR};
+
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $file=pkgfile($package,"install");
- my $srcdir = '.';
my @install;
if ($file) {
@install=filedoublearray($file); # no globbing yet
}
- $srcdir = $dh{SOURCEDIR}."/" if defined $dh{SOURCEDIR};
-
if (($package eq $dh{FIRSTPACKAGE} || $dh{PARAMS_ALL}) && @ARGV) {
push @install, [@ARGV];
}
@@ -178,7 +180,7 @@ if ($dh{LIST_MISSING}) {
-f || -l || return;
$_="$File::Find::dir/$_";
push @missing, $_ unless /$installed/;
- }, './debian/tmp');
+ }, $srcdir);
if (@missing) {
warning "$_ not installed" foreach @missing;
}
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 9d7c03f4..f4930054 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -65,7 +65,7 @@ See example below.
=head1 EXAMPLES
Suppose that your source package produces libfoo1, libfoo-dev, and
-libfoo-bin binary packages. libfoo-bin links against libfoo, and should
+libfoo-bin binary packages. libfoo-bin links against libfoo1, and should
depend on it. In your rules file, first run dh_makeshlibs, then dh_shlibdeps:
dh_makeshlibs