summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Buildsystems.pm3
-rw-r--r--debhelper.pod4
-rw-r--r--debian/changelog2
-rw-r--r--doc/TODO3
4 files changed, 8 insertions, 4 deletions
diff --git a/Debian/Debhelper/Dh_Buildsystems.pm b/Debian/Debhelper/Dh_Buildsystems.pm
index a14ff037..22f80f9e 100644
--- a/Debian/Debhelper/Dh_Buildsystems.pm
+++ b/Debian/Debhelper/Dh_Buildsystems.pm
@@ -20,10 +20,11 @@ use constant BUILD_STEPS => qw(configure build test install clean);
# build systems MUST be added to the END of the list.
our @BUILDSYSTEMS = (
"autoconf",
+ (! compat(7) ? "perl_build" : ()),
"perl_makemaker",
"makefile",
"python_distutils",
- "perl_build",
+ (compat(7) ? "perl_build" : ()),
"cmake",
"ant",
"qmake",
diff --git a/debhelper.pod b/debhelper.pod
index a7735b1f..554b7f78 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -531,6 +531,10 @@ can cause some packages to fail to build.
dh requires the sequence to run be specified as the first parameter, and
any switches come after it. Ie, use "dh $@ --foo", not "dh --foo $@"
+=item
+
+dh_auto_* prefer to use perl's Module::Build in preference to Makefile.PL.
+
=back
=back
diff --git a/debian/changelog b/debian/changelog
index 5df9e2c9..0ca846ab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -26,6 +26,8 @@ debhelper (7.9.1) UNRELEASED; urgency=low
file with a name like HISTORY. Closes: #582749
* dh_installchangelogs: Also look for changelog files in doc(s)
subdirectories. Closes: #521258
+ * In v8 mode, prefer the perl_build buildsystem over perl_makemaker.
+ Closes: #578805
-- Joey Hess <joeyh@debian.org> Mon, 17 May 2010 20:01:19 -0400
diff --git a/doc/TODO b/doc/TODO
index 1f500806..6aa3d71b 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -1,11 +1,8 @@
v8:
-* better package arch filtering for -N , -p (#576990)
* Support DEB_BUILD_OPTIONS=debug ; maybe also support passing
-g -O2 by default. See patch (and discussion of why this breaks
compatability) in #544844.
-* Reorder build systems list. perl_build before perl_makemaker.
- Any other changes? #578805
v9: