summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-suid2
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_python47
3 files changed, 37 insertions, 19 deletions
diff --git a/autoscripts/postinst-suid b/autoscripts/postinst-suid
index d0d16c06..db4bc6dd 100644
--- a/autoscripts/postinst-suid
+++ b/autoscripts/postinst-suid
@@ -2,7 +2,7 @@ if [ "$1" = "configure" ]; then
if which suidregister >/dev/null 2>&1 && [ -e /etc/suid.conf ]; then
suidregister -s #PACKAGE# /#FILE# #OWNER# #GROUP# #PERMS#
elif [ -e /#FILE# ]; then
- chown #OWNER#.#GROUP# /#FILE#
+ chown #OWNER#:#GROUP# /#FILE#
chmod #PERMS# /#FILE#
fi
fi
diff --git a/debian/changelog b/debian/changelog
index 7b6585a3..65e14054 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.63) unstable; urgency=low
+
+ * dh_python: patch from Josselin to fix generated depends. Closes: #204717
+ * dh_pythn: also stylistic and tab damage fixes
+
+ -- Joey Hess <joeyh@debian.org> Mon, 11 Aug 2003 15:33:16 -0400
+
debhelper (4.1.62) unstable; urgency=low
* Fix a bug in quoted section parsing that put the quotes in the parsed
diff --git a/dh_python b/dh_python
index 9bbffa4c..f677ee2e 100755
--- a/dh_python
+++ b/dh_python
@@ -98,8 +98,27 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
delsubstvar($package, "python:Depends");
- # Check for current python dependencies
my @dirs = ("usr/lib/site-python", "usr/lib/$package", "usr/share/$package", "usr/lib/games/$package", "usr/share/games/$package", @ARGV );
+
+ my $dep_on_python = 0;
+ my $strong_dep = 0;
+ my $look_for_pythonXY = 1;
+
+ # First, the case of python-foo
+ if ($package =~ /^python-/) {
+ $dep_on_python = 1;
+ $strong_dep = 1;
+ my $pack = $package;
+ $pack =~ s/^python/python$python_version/;
+ if (grep { "$_" eq "$pack" } GetPackages()) {
+ addsubstvar($package, "python:Depends", $pack);
+ }
+ else {
+ push @dirs, "usr/lib/python$python_version/site-packages" ;
+ $look_for_pythonXY = 0;
+ }
+ }
+
@dirs = grep -d, map "$tmp/$_", @dirs;
my $deps = 0;
@@ -141,19 +160,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
# Dependencies on current python
- my $dep_on_python = 0;
- my $strong_dep = 0;
$dep_on_python = 1 if $deps;
$strong_dep = 1 if($deps & PY_MODULE);
- if ($package =~ /^python-/) {
- my $pack = $package;
- $pack =~ s/^python/python$python_version/;
- if (grep { "$_" eq "$pack" } GetPackages()) {
- addsubstvar($package, "python:Depends", $pack);
- $dep_on_python = 1;
- $strong_dep = 1;
- }
- }
+
if ($dep_on_python) {
addsubstvar($package, "python:Depends", $python, ">= $python_version");
if ($strong_dep) {
@@ -168,13 +177,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Look for specific pythonX.Y modules
foreach my $pyver (@python_allversions) {
my $pydir="/usr/lib/$pyver/site-packages";
- if (grep -d,"$tmp$pydir") {
- find sub {
- return unless -f;
- $verdeps{$pyver} |= PY_MODULE if /\.py$/;
- }, "$tmp$pydir";
+ if ($look_for_pythonXY) {
+ if (grep -d,"$tmp$pydir") {
+ find sub {
+ return unless -f;
+ $verdeps{$pyver} |= PY_MODULE if /\.py$/;
+ }, "$tmp$pydir";
+ }
}
-
+
# Go for the dependencies
addsubstvar($package, "python:Depends", $pyver) if $verdeps{$pyver};