summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-gconf-defaults2
-rw-r--r--autoscripts/postrm-gconf-defaults2
-rw-r--r--debian/changelog1
-rwxr-xr-xdh_gconf20
4 files changed, 20 insertions, 5 deletions
diff --git a/autoscripts/postinst-gconf-defaults b/autoscripts/postinst-gconf-defaults
index 1d84aa40..eff244a5 100644
--- a/autoscripts/postinst-gconf-defaults
+++ b/autoscripts/postinst-gconf-defaults
@@ -1,3 +1,3 @@
if [ "$1" = "configure" ] && which update-gconf-defaults >/dev/null 2>&1; then
- update-gconf-defaults
+ update-gconf-defaults #OPT#
fi
diff --git a/autoscripts/postrm-gconf-defaults b/autoscripts/postrm-gconf-defaults
index 46844981..b15de676 100644
--- a/autoscripts/postrm-gconf-defaults
+++ b/autoscripts/postrm-gconf-defaults
@@ -1,3 +1,3 @@
if which update-gconf-defaults >/dev/null 2>&1; then
- update-gconf-defaults
+ update-gconf-defaults #OPT#
fi
diff --git a/debian/changelog b/debian/changelog
index 0129159d..29fa6d1e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ debhelper (7.1.2) UNRELEASED; urgency=low
* dh: Fix typo. Closes: #509754
* debhelper.pod: Fix typo. Closes: #510180
+ * dh_gconf: Support mandatory settings. Closes: #513923
-- Joey Hess <joeyh@debian.org> Thu, 25 Dec 2008 16:26:36 -0500
diff --git a/dh_gconf b/dh_gconf
index 84a6a6cc..8c30de73 100755
--- a/dh_gconf
+++ b/dh_gconf
@@ -27,6 +27,11 @@ installed into usr/share/gconf/defaults/10_package in the package build
directory, with "package" replaced by the package name. Some postinst and
postrm fragments will be generated to launch update-gconf-defaults.
+If a file named debian/package.gconf-mandatory exists, then it is
+installed into usr/share/gconf/mandatory/10_package in the package build
+directory, with "package" replaced by the package name, and similar
+postinst and postrm fragments will be generated.
+
The gconf-schemas and update-gconf-defaults scripts are provided by the
gconf2 package. An appropriate dependency will be generated in
${misc:Depends}.
@@ -57,13 +62,22 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $gconf_dep = 0;
+ my $mandatory = pkgfile($package, "gconf-mandatory");
+ if ($mandatory ne '') {
+ doit("mkdir","-p","$tmp/usr/share/gconf/mandatory");
+ doit("install","-p","-m644",$mandatory,"$tmp/usr/share/gconf/mandatory/${priority}_$package");
+ autoscript($package,"postinst","postinst-gconf-defaults","s%#OPT#%--mandatory%");
+ autoscript($package,"postrm","postrm-gconf-defaults","s%#OPT#%--mandatory%");
+ addsubstvar($package, "misc:Depends", "gconf2 (>= 2.24.0-5)");
+ $gconf_dep = 1;
+ }
my $defaults = pkgfile($package,"gconf-defaults");
if ($defaults ne '') {
doit("mkdir","-p","$tmp/usr/share/gconf/defaults");
doit("install","-p","-m644",$defaults,"$tmp/usr/share/gconf/defaults/${priority}_$package");
- autoscript($package,"postinst","postinst-gconf-defaults");
- autoscript($package,"postrm","postrm-gconf-defaults");
- addsubstvar($package, "misc:Depends", "gconf2 (>= 2.12.1-1)");
+ autoscript($package,"postinst","postinst-gconf-defaults","s%#OPT#%%");
+ autoscript($package,"postrm","postrm-gconf-defaults","s%#OPT#%%");
+ addsubstvar($package, "misc:Depends", "gconf2 (>= 2.12.1-1)") unless $gconf_dep;
$gconf_dep = 1;
}