summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_auto_configure3
2 files changed, 5 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 23d9b270..cf095ac8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ debhelper (7.0.2) UNRELEASED; urgency=low
* dh: Optimise the case where the binary-arch or binary-indep sequence is
run and there are no packages of that type.
+ * dh_auto_configure: Set PERL_MM_USE_DEFAULT when configuring MakeMaker
+ packages to avoid interactive prompts.
-- Joey Hess <joeyh@debian.org> Thu, 24 Apr 2008 14:10:56 -0400
diff --git a/dh_auto_configure b/dh_auto_configure
index 4b01889b..6e56c953 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -85,6 +85,9 @@ if (-x "configure") {
doit("./configure", @opts, @{$dh{U_PARAMS}});
}
elsif (-e "Makefile.PL") {
+ # If set to a true value then MakeMaker's prompt function will
+ # # always return the default without waiting for user input.
+ $ENV{PERL_MM_USE_DEFAULT}=1;
doit("perl", "Makefile.PL", "INSTALLDIRS=vendor", @{$dh{U_PARAMS}});
}