summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_makeshlibs14
2 files changed, 18 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 6faf5ef5..868c699e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (3.0.13) unstable; urgency=low
+
+ * dh_makeshlibs: more support for nasty soname formats, Closes: #90520
+
+ -- Joey Hess <joeyh@debian.org> Wed, 21 Mar 2001 15:00:42 -0800
+
debhelper (3.0.12) unstable; urgency=low
* Applied a patch from Anton Zinoviev <anton@lml.bas.bg> to pass -e
diff --git a/dh_makeshlibs b/dh_makeshlibs
index e8006688..346a5f5a 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -91,8 +91,18 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# objdump is anything actually added.
open (FIND, "find $tmp -type f -name '*.so*' |");
while (<FIND>) {
- my ($library, $major) =
- `objdump -p $_` =~ m/\s+SONAME\s+(.+)\.so\.(.+)/;
+ my ($library, $major);
+ my $objdump=`objdump -p $_`;
+ if ($objdump=~m/\s+SONAME\s+(.+)\.so\.(.+)/) {
+ # proper soname format
+ $library=$1;
+ $major=$2;
+ }
+ elsif ($objdump=~m/\s+SONAME\s+(.+)-(.+)\.so/) {
+ # idiotic crap soname format
+ $library=$1;
+ $major=$2;
+ }
if (defined($dh{M_PARAMS}) && $dh{M_PARAMS} ne '') {
$major=$dh{M_PARAMS};