summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_installchangelogs10
2 files changed, 12 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index d92f9b79..d424ff91 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.51) unstable; urgency=low
+
+ * dh_installchangelogs: Install debian/NEWS as NEWS.Debian, even for native
+ packages. This doesn't follow the lead of the changelog for native
+ packages for the reasons discussed in bug #192089
+
+ -- Joey Hess <joeyh@debian.org> Fri, 4 Jul 2003 00:34:24 -0400
+
debhelper (4.1.50) unstable; urgency=low
* dh_clean: make -X work for debian/substvars file.
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 4c211e55..66a02558 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -26,10 +26,9 @@ files named debian/package.changelog exist, they will be used in preference
to debian/changelog.)
Parallelling the debian changelog handling, this program also takes care of
-debian NEWS files. If there is a debian/NEWS file, it is installed as
-usr/share/doc/package/NEWS for native packages, and as
-usr/share/doc/package/NEWS.Debian for non-native packages. debian/package.NEWS
-files can also be used.
+NEWS.Debian files. If there is a debian/NEWS file, it is installed as
+usr/share/doc/package/NEWS.Debian. debian/package.NEWS files can also be
+used.
If an upstream changelog file is specified as an option, and the package is
not a native debian package, then this upstream changelog will be installed
@@ -73,11 +72,10 @@ if (isnative($dh{MAINPACKAGE}) && defined $upstream) {
}
my $changelog_name="changelog.Debian";
-my $news_name="NEWS.Debian";
if (isnative($dh{MAINPACKAGE})) {
$changelog_name='changelog';
- $news_name='NEWS';
}
+my $news_name="NEWS.Debian";
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);