summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_install6
2 files changed, 13 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 20fd27bd..b7913c61 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.47) unstable; urgency=low
+
+ * dh_install: recalculate automatic $dest eash time through the glob loop.
+ It might change if there are multiple wildcards Closes: #196344
+
+ -- Joey Hess <joeyh@debian.org> Mon, 16 Jun 2003 13:35:27 -0400
+
debhelper (4.1.46) unstable; urgency=low
* Added dh_scrollkeeper, by Ross Burton.
diff --git a/dh_install b/dh_install
index c37b9d35..5dff4626 100755
--- a/dh_install
+++ b/dh_install
@@ -127,6 +127,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
foreach my $set (@install) {
my $dest;
+ my $tmpdest=0;
if (! defined $dh{AUTODEST} && @$set > 1) {
$dest=pop @$set;
@@ -144,6 +145,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
$dest=~s/^(.*\/)?\Q$strip\E//;
$dest=dirname($dest);
+ $tmpdest=1;
}
# Make sure the destination directory exists.
@@ -174,6 +176,10 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
else {
doit("cp", "-a", $src, "$tmp/$dest/");
}
+
+ if ($tmpdest) {
+ $dest=undef;
+ }
}
}
}