summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm3
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdh_builddeb4
-rwxr-xr-xdh_strip2
5 files changed, 12 insertions, 5 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 7ebbe61b..3bf7df18 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -139,7 +139,8 @@ sub doit {
verbose_print(escape_shell(@_));
if (! $dh{NO_ACT}) {
- system(@_) == 0 || error("command returned error code");
+ my $ret=system(@_);
+ $ret == 0 || error("command returned error code $ret");
}
}
diff --git a/debian/changelog b/debian/changelog
index 74d893bb..a98acf01 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (4.1.7) unstable; urgency=low
+
+ * dh_builddeb(1): It's --filename, not --name. Closes: #160151
+
+ -- Joey Hess <joeyh@debian.org> Sun, 8 Sep 2002 20:05:07 -0400
+
debhelper (4.1.6) unstable; urgency=low
* Clarified dh_perl man page. Closes: #159332
diff --git a/debian/control b/debian/control
index 598ce839..b07c2116 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl (>= 5.6.1), fileutils (>= 4.0-2.1), file (>= 3.23-1), debconf-utils (>= 1.1.1), dpkg-dev (>= 1.9.0)
-Standards-Version: 3.5.6.1
+Standards-Version: 3.5.7.0
Package: debhelper
Architecture: all
diff --git a/dh_builddeb b/dh_builddeb
index 07029c07..04b40f84 100755
--- a/dh_builddeb
+++ b/dh_builddeb
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh_builddeb> [S<I<debhelper options>>] [B<--destdir=>I<directory>] [B<--name=>I<filename>] [S<B<--> I<params>>]
+B<dh_builddeb> [S<I<debhelper options>>] [B<--destdir=>I<directory>] [B<--filename=>I<name>] [S<B<--> I<params>>]
=head1 DESCRIPTION
@@ -27,7 +27,7 @@ packages.
Use this if you want the generated .deb files to be put in a directory
other than the default of ".."
-=item B<--name=>I<filename>
+=item B<--filename=>I<name>
Use this if you want to force the generated .deb file to have a particular
file name. Does not work well if more than one .deb is generated!
diff --git a/dh_strip b/dh_strip
index 31d51aff..ac51cd5e 100755
--- a/dh_strip
+++ b/dh_strip
@@ -12,7 +12,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh_strip> [S<I<debhelper options>>] [B<-X>I<item>]
+B<dh_strip> [S<I<debhelper options>>] [B<-X>I<item>] [item]
=head1 DESCRIPTION