summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm4
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_md5sums1
3 files changed, 12 insertions, 2 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index c9910bad..41b7a634 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -117,7 +117,7 @@ sub escape_shell {
# This does make -V"foo bar" turn into "-Vfoo bar",
# but that will be parsed identically by the shell
# anyway..
- $word=~s/([\n`\$"\\])/\$1/g;
+ $word=~s/([\n`\$"\\])/\\$1/g;
push @ret, "\"$word\"";
}
else {
@@ -439,7 +439,7 @@ sub addsubstvar {
}
if (length $line) {
- complex_doit("(grep -s -v ${substvar} $substvarfile; echo '${substvar}=$line') > $substvarfile.new");
+ complex_doit("(grep -s -v ${substvar} $substvarfile; echo ".escape_shell("${substvar}=$line").") > $substvarfile.new");
doit("mv", "$substvarfile.new", $substvarfile);
}
else {
diff --git a/debian/changelog b/debian/changelog
index 70e779cb..3683986d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (4.1.32) unstable; urgency=low
+
+ * dh_md5sums: note that it's used by debsums. Closes: #181521
+ * Make addsubstvars() escape the value of the variable before passing it to
+ the shell. Closes: #178524
+ * Fixed escape_shell()'s escaping of a few things.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 18 Feb 2003 19:01:45 -0500
+
debhelper (4.1.31) unstable; urgency=low
* Added dh_installcatalogs, for sgml (and later xml) catalogs. By
diff --git a/dh_md5sums b/dh_md5sums
index 616a8d89..4a0e460c 100755
--- a/dh_md5sums
+++ b/dh_md5sums
@@ -18,6 +18,7 @@ B<dh_md5sums> [S<I<debhelper options>>] [B<-x>] [B<-X>I<item>] [B<--include-conf
dh_md5sums is a debhelper program that is responsible for generating
a DEBIAN/md5sums file, which lists the md5sums of each file in the package.
+These files are used by the debsums package.
All files in DEBIAN/ are omitted from the md5sums file, as are all
conffiles (unless you use the --include-conffiles switch).