summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-doc-base4
-rw-r--r--autoscripts/prerm-doc-base5
-rw-r--r--debian/changelog7
3 files changed, 12 insertions, 4 deletions
diff --git a/autoscripts/postinst-doc-base b/autoscripts/postinst-doc-base
index a53ed7bf..fce4d17e 100644
--- a/autoscripts/postinst-doc-base
+++ b/autoscripts/postinst-doc-base
@@ -1,3 +1,3 @@
-if command -v install-docs >/dev/null 2>&1; then
- install-docs -i /usr/share/doc-base/#PACKAGE#
+if [ "$1" = configure ] && command -v install-docs >/dev/null 2>&1; then
+ install-docs -i /usr/share/doc-base/#DOC-ID#
fi
diff --git a/autoscripts/prerm-doc-base b/autoscripts/prerm-doc-base
index 339361a5..d2b07ebc 100644
--- a/autoscripts/prerm-doc-base
+++ b/autoscripts/prerm-doc-base
@@ -1,3 +1,4 @@
-if command -v install-docs >/dev/null 2>&1; then
- install-docs -r #PACKAGE#
+if [ "$1" = remove -o "$1" = upgrade ] && \
+ command -v install-docs >/dev/null 2>&1; then
+ install-docs -r #DOC-ID#
fi
diff --git a/debian/changelog b/debian/changelog
index eb0c4dd8..a8b7c62e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.0.93) unstable; urgency=low
+
+ * Patch from Pedro Guerreiro to make install-docs only be called on
+ configure and remove/upgrade. Closes: #62513
+
+ -- Joey Hess <joeyh@debian.org> Sun, 16 Apr 2000 19:05:52 -0700
+
debhelper (2.0.92) unstable; urgency=low
* Detect changelog parse failures and use a better error message.