summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_installinfo22
2 files changed, 17 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index a4527068..2ce69c2f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (2.0.41) unstable; urgency=low
+
+ * dh_installinfo: use FHS info dir. I wonder how I missed that..
+
+ -- Joey Hess <joeyh@master.debian.org> Mon, 6 Sep 1999 13:22:08 -0700
+
debhelper (2.0.40) unstable; urgency=low
* FHS complience. Patch from Johnie Ingram <johnie@netgod.net>.
diff --git a/dh_installinfo b/dh_installinfo
index b6ae40f9..55deb362 100755
--- a/dh_installinfo
+++ b/dh_installinfo
@@ -1,9 +1,9 @@
#!/usr/bin/perl -w
#
-# Reads debian/info, installs all files listed there into /usr/info
+# Reads debian/info, installs all files listed there into /usr/share/info
# and puts appropriate commands into the postinst.
-BEGIN { push @INC, "debian", "/usr/lib/debhelper" }
+BEGIN { push @INC, "debian", "/usr/share/debhelper" }
use Dh_Lib;
init();
@@ -22,12 +22,12 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
if (@info) {
- if ( ! -d "$TMP/usr/info") {
- doit("install","-d","$TMP/usr/info");
+ if ( ! -d "$TMP/usr/share/info") {
+ doit("install","-d","$TMP/usr/share/info");
}
- doit("cp",@info,"$TMP/usr/info");
- doit("chmod","-R", "go=rX","$TMP/usr/info/");
- doit("chmod","-R", "u+rw","$TMP/usr/info/");
+ doit("cp",@info,"$TMP/usr/share/info");
+ doit("chmod","-R", "go=rX","$TMP/usr/share/info/");
+ doit("chmod","-R", "u+rw","$TMP/usr/share/info/");
}
foreach $file (@info) {
@@ -35,7 +35,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
# a tree of info files.
if ($file=~/\.info$/ && ! $dh{NOSCRIPTS}) {
# Figure out what section this file goes in.
- my $section;
+ my $section='';
open (IN, "<$file") || die "$file: $!";
while (<IN>) {
if (/INFO-DIR-SECTION\s+(.*)/) {
@@ -45,15 +45,15 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
close IN;
- my $fn="/usr/info/".Dh_Lib::basename($file);
+ my $fn="/usr/share/info/".Dh_Lib::basename($file);
if ($section ne '') {
autoscript($PACKAGE,"postinst","postinst-info",
- "s/#SECTION#/$section/;s:#FILE#:$fn:");
+ "s/#SECTION#/$section/g;s:#FILE#:$fn:");
}
else {
autoscript($PACKAGE,"postinst","postinst-info-nosection",
- "s/#FILE#/$fn/");
+ "s:#FILE#:$fn:");
}
autoscript($PACKAGE,"prerm","prerm-info", "s:#FILE#:$fn:");
}