summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm3
-rw-r--r--debian/changelog3
2 files changed, 5 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 1a01c34e..c62041fe 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -40,7 +40,8 @@ sub configure {
# # always return the default without waiting for user input.
$ENV{PERL_MM_USE_DEFAULT}=1;
doit("perl", "Makefile.PL", "INSTALLDIRS=vendor",
- "create_packlist=0", @_);
+ "create_packlist=0", "--skipdeps",
+ @_);
}
sub install {
diff --git a/debian/changelog b/debian/changelog
index b345d4ba..3a9a9f3f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -19,6 +19,9 @@ debhelper (7.2.11) UNRELEASED; urgency=low
* dh: Support --with addon,addon,...
Closes: #528178
+ * dh_auto_configure: Add --skipdeps when running Makefile.PL,
+ to prevent Module::Install from trying to download dependencies.
+ Closes: #528235
-- Joey Hess <joeyh@debian.org> Mon, 11 May 2009 14:50:33 -0400