summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_installchangelogs2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index fa5b4572..6892bae3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -22,6 +22,8 @@ debhelper (7.9.1) UNRELEASED; urgency=low
(Ie, use "dh $@ --foo", not "dh --foo $@")
This avoids ambiguities when parsing options to be passed on to debhelper
commands. (See #570039)
+ * dh_installchangelogs: Support packages placing their changelog in a
+ file with a name like HISTORY. Closes: #582749
-- Joey Hess <joeyh@debian.org> Mon, 17 May 2010 20:01:19 -0400
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 4bf97dcc..87ac11bd 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -85,7 +85,7 @@ my $changelog_name="changelog.Debian";
if (! defined $upstream) {
if (! isnative($dh{MAINPACKAGE}) && !compat(6)) {
my @files=sort glob("*");
- foreach my $name (qw{changelog changes changelog.txt changes.txt}) {
+ foreach my $name (qw{changelog changes changelog.txt changes.txt history history.txt}) {
my @matches=grep {
lc $_ eq $name && -s $_ && ! excludefile($_)
} @files;