summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-init-norestart2
-rw-r--r--autoscripts/postinst-init-norestart-invoke2
-rw-r--r--autoscripts/prerm-doc2
-rw-r--r--autoscripts/prerm-doc-base2
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_suidregister1
6 files changed, 11 insertions, 5 deletions
diff --git a/autoscripts/postinst-init-norestart b/autoscripts/postinst-init-norestart
index 4f1c63f9..a5741654 100644
--- a/autoscripts/postinst-init-norestart
+++ b/autoscripts/postinst-init-norestart
@@ -1,7 +1,7 @@
if [ -x "/etc/init.d/#SCRIPT#" ]; then
update-rc.d #SCRIPT# #INITPARMS# >/dev/null
if [ "$1" = "configure" ]; then
- if [ -z "$2" -o "$2" = "<unknown>" ]; then
+ if [ -z "$2" ] || [ "$2" = "<unknown>" ]; then
/etc/init.d/#SCRIPT# start
fi
fi
diff --git a/autoscripts/postinst-init-norestart-invoke b/autoscripts/postinst-init-norestart-invoke
index 440e8c78..be1751c8 100644
--- a/autoscripts/postinst-init-norestart-invoke
+++ b/autoscripts/postinst-init-norestart-invoke
@@ -1,7 +1,7 @@
if [ -x "/etc/init.d/#SCRIPT#" ]; then
update-rc.d #SCRIPT# #INITPARMS# >/dev/null
if [ "$1" = "configure" ]; then
- if [ -z "$2" -o "$2" = "<unknown>" ]; then
+ if [ -z "$2" ] || [ "$2" = "<unknown>" ]; then
invoke-rc.d #SCRIPT# start
fi
fi
diff --git a/autoscripts/prerm-doc b/autoscripts/prerm-doc
index 05abb495..bd778683 100644
--- a/autoscripts/prerm-doc
+++ b/autoscripts/prerm-doc
@@ -1,4 +1,4 @@
-if [ "$1" = "upgrade" ] || [ "$1" = "remove" ] && [ -L /usr/doc/#PACKAGE#
+if [ "$1" = "upgrade" ] || [ "$1" = "remove" ] && [ -L /usr/doc/#PACKAGE# ]
then
rm -f /usr/doc/#PACKAGE#
fi
diff --git a/autoscripts/prerm-doc-base b/autoscripts/prerm-doc-base
index 7ec95b7c..c57d999a 100644
--- a/autoscripts/prerm-doc-base
+++ b/autoscripts/prerm-doc-base
@@ -1,4 +1,4 @@
-if [ "$1" = remove -o "$1" = upgrade ] && \
+if [ "$1" = remove ] || [ "$1" = upgrade ] && \
which install-docs >/dev/null 2>&1; then
install-docs -r #DOC-ID#
fi
diff --git a/debian/changelog b/debian/changelog
index 221eb8cb..b7d86363 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.0.15) unstable; urgency=low
+
+ * Stupid, evil typo.
+ * Fixed the tests clint didn't show me.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 20 Jun 2002 20:57:06 -0400
+
debhelper (4.0.14) unstable; urgency=low
* In script fragments, use more posix tests, no -a or -o, no parens.
diff --git a/dh_suidregister b/dh_suidregister
index 05db06e1..263e7278 100755
--- a/dh_suidregister
+++ b/dh_suidregister
@@ -104,7 +104,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
if (@files) {
- # So we would have registered some files before.
warning("This program should no longer be used. Please read the dh_suidregister(1) man page.");
$notused=0;
}