summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debhelper.pod2
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_install8
3 files changed, 11 insertions, 6 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 67cfbe7..08c5115 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -64,7 +64,7 @@ then they will be used in preference to other, more general files.
In many cases, these config files are used to specify various types of
files. Documentation or example files to install, files to move, and so on.
When appropriate, in cases like these, you can use standard shell wildcard
-characters ('?' and '*') in the files.
+characters ('?' and '*' and '[..]' character classes) in the files.
=head1 SHARED DEBHELPER OPTIONS
diff --git a/debian/changelog b/debian/changelog
index 0429fd9..3bc66f6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.0.9) unstable; urgency=low
+
+ * dh_install: glob relative to --sourcedir. Closes: #147908
+ * Documented what globbing is allowed.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 23 May 2002 12:28:30 -0400
+
debhelper (4.0.8) unstable; urgency=low
* Don't leak regex characters from -X when generating DH_EXCLUDE_FIND.
diff --git a/dh_install b/dh_install
index 4aa7142..65a9977 100755
--- a/dh_install
+++ b/dh_install
@@ -100,7 +100,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
@install=filedoublearray($file); # no globbing yet
}
- $srcdir = $dh{SOURCEDIR} if defined $dh{SOURCEDIR};
+ $srcdir = $dh{SOURCEDIR}."/" if defined $dh{SOURCEDIR};
if (($package eq $dh{FIRSTPACKAGE} || $dh{PARAMS_ALL}) && @ARGV) {
push @install, [@ARGV];
@@ -118,8 +118,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (! defined $dh{AUTODEST} && @$set > 1) {
$dest=pop @$set;
}
-
- foreach my $src (map { glob } @$set) { # glob now
+ # glob now, relative to srcdir
+ foreach my $src (map { glob "$srcdir/$_" } @$set) {
next if excludefile($src);
if (! defined $dest) {
@@ -129,8 +129,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$dest=dirname($dest);
}
- $src = "$srcdir/$src"; # do this now, to avoid the parsing above
-
# Make sure the destination directory exists.
if (! -e "$tmp/$dest") {
doit("install","-d","$tmp/$dest");