summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdh_installman6
2 files changed, 7 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 594ef7c8..fa04d078 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
debhelper (7.4.21) UNRELEASED; urgency=low
* dh_installman: Support .so links relative to the current section.
+ * dh_installman: Avoid converting .so links to symlinks if the link
+ target is not present in the same binary package, on advice of
+ Colin Watson. (To support eventual so search paths.)
-- Joey Hess <joeyh@debian.org> Mon, 17 May 2010 20:01:19 -0400
diff --git a/dh_installman b/dh_installman
index 1a5750b8..703b70bc 100755
--- a/dh_installman
+++ b/dh_installman
@@ -248,8 +248,10 @@ sub find_so_man {
$solink="../$solink";
}
- push @sofiles,"$File::Find::dir/$_";
- push @sodests,$solink;
+ if (-e $solink || -e "$solink.gz") {
+ push @sofiles,"$File::Find::dir/$_";
+ push @sodests,$solink;
+ }
}
}