summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_installman10
2 files changed, 13 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 95a3b64b..9c76e9d3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (5.0.35) UNRELEASED; urgency=low
+
+ * dh_installman: When --language is used, be smarter about stripping
+ language codes from man page filenames. Only strip things that look like
+ codes that match the specified languages. Closes: #366645
+
+ -- Joey Hess <joeyh@debian.org> Wed, 10 May 2006 20:07:40 -0400
+
debhelper (5.0.34) unstable; urgency=low
* dh_installcatalogs: Make sure that /etc/sgml exists. Closes: #364946
diff --git a/dh_installman b/dh_installman
index e8ed27da..7f39b934 100755
--- a/dh_installman
+++ b/dh_installman
@@ -148,14 +148,14 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# language code to the filename, so detect that and
# redirect to appropriate directory, stripping the code.
($langcode)=$basename=~m/.*\.([a-z][a-z](?:_[A-Z][A-Z])?)\.(?:[1-9]|man)/;
- if (defined $langcode && $langcode ne '') {
- # Strip the language code from the instname.
- $instname=~s/\.$langcode$//;
- }
}
elsif ($dh{LANGUAGE} ne 'C') {
$langcode=$dh{LANGUAGE};
- ($instname)=$basename=~m/(.*?)\./;
+ }
+
+ if (defined $langcode && $langcode ne '') {
+ # Strip the language code from the instname.
+ $instname=~s/\.$langcode$//;
}
if (defined $langcode && $langcode ne '') {