summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_bugfiles12
-rwxr-xr-xdh_clean12
-rwxr-xr-xdh_compress18
-rwxr-xr-xdh_gconf28
-rwxr-xr-xdh_install25
-rwxr-xr-xdh_installcatalogs23
-rwxr-xr-xdh_installchangelogs36
-rwxr-xr-xdh_installcron24
-rwxr-xr-xdh_installdeb47
-rwxr-xr-xdh_installdebconf45
-rwxr-xr-xdh_installdirs13
-rwxr-xr-xdh_installdocs61
-rwxr-xr-xdh_installemacsen27
-rwxr-xr-xdh_installexamples23
-rwxr-xr-xdh_installifupdown19
-rwxr-xr-xdh_installinfo13
-rwxr-xr-xdh_installinit27
-rwxr-xr-xdh_installlogcheck27
-rwxr-xr-xdh_installman16
-rwxr-xr-xdh_installmenu23
-rwxr-xr-xdh_installmime20
-rwxr-xr-xdh_installmodules34
-rwxr-xr-xdh_installpam17
-rwxr-xr-xdh_installppp19
-rwxr-xr-xdh_installudev17
-rwxr-xr-xdh_installwm17
-rwxr-xr-xdh_link19
-rwxr-xr-xdh_lintian18
-rwxr-xr-xdh_makeshlibs16
-rwxr-xr-xdh_movefiles18
31 files changed, 470 insertions, 248 deletions
diff --git a/debian/changelog b/debian/changelog
index 25cfce20..38923d55 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,12 @@
debhelper (7.4.1) UNRELEASED; urgency=low
+ [ Steve Langasek ]
* dh_installinit: Support upstart job files, and provide compatibility
symlinks in /etc/init.d for sysv-rc implementations. Closes: #536035.
+ [ Joey Hess ]
+ * Add FILES sections to man pages. Closes: #545041
+
-- Steve Langasek <vorlon@debian.org> Thu, 06 Aug 2009 03:01:43 -0700
debhelper (7.4.0) unstable; urgency=low
diff --git a/dh_bugfiles b/dh_bugfiles
index 58220ad9..a5a72a91 100755
--- a/dh_bugfiles
+++ b/dh_bugfiles
@@ -19,26 +19,26 @@ dh_bugfiles is a debhelper program that is responsible for installing
bug reporting customization files (bug scripts and/or bug control files
and/or presubj files) into package build directories.
-This helper program installs the following files if they are found:
+=head1 FILES
-=over 3
+=over 4
-=item B<debian/package.bug-script>
+=item debian/I<package>.bug-script
-It is the script to be run by the bug reporting program for generating a bug
+This is the script to be run by the bug reporting program for generating a bug
report template. This file is installed as F<usr/share/bug/package> in the
package build directory if no other types of bug reporting customization
files are going to be installed for the package in question. Otherwise,
this file is installed as F<usr/share/bug/package/script>. Finally, the
installed script is given execute permissions.
-=item B<debian/package.bug-control>
+=item debian/I<package>.bug-control
It is the bug control file containing some directions for the bug reporting
tool. This file is installed as F<usr/share/bug/package/control> in the
package build directory.
-=item B<debian/package.bug-presubj>
+=item debian/I<package>.bug-presubj
The contents of this file are displayed to the user by the bug reporting
tool before allowing the user to write a bug report on the package to the
diff --git a/dh_clean b/dh_clean
index 1213f6ca..bc5bc579 100755
--- a/dh_clean
+++ b/dh_clean
@@ -22,14 +22,22 @@ debhelper commands. It also removes common files that should not appear in a
debian diff:
#*# *~ DEADJOE *.orig *.rej *.SUMS TAGS .deps/* *.P *-stamp
-The debian/clean file can list other files to be removed.
-
It does not run "make clean" to clean up after the build process. Use
L<dh_auto_clean(1)> to do things like that.
dh_clean (or "dh clean") should be the last debhelper command run in the
clean target in debian/rules.
+=head1 FILES
+
+=over 4
+
+=item debian/clean
+
+Can list other files to be removed.
+
+=back
+
=head1 OPTIONS
=over 4
diff --git a/dh_compress b/dh_compress
index 3d6c1b69..f624a175 100755
--- a/dh_compress
+++ b/dh_compress
@@ -29,12 +29,18 @@ that appear to be already compressed based on their extensions), and all
changelog files. Plus PCF fonts underneath usr/X11R6/lib/X11/fonts/ and
usr/share/fonts/X11/
-If a debian/package.compress file exists, the default files are not
-compressed. Instead, the debian/packages.compress is ran as a shell
-script, and all filenames that the shell script outputs will be compressed.
-The shell script will be run from inside the package build directory. Note
-though that using -X is a much better idea in general; you should only use a
-debian/package.compress file if you really need to.
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.compress
+
+If this file exists, the default files are not compressed. Instead, the
+file is ran as a shell script, and all filenames that the shell script
+outputs will be compressed. The shell script will be run from inside the
+package build directory. Note though that using -X is a much better idea in
+general; you should only use a debian/package.compress file if you really
+need to.
=head1 OPTIONS
diff --git a/dh_gconf b/dh_gconf
index df8573a3..514aae79 100755
--- a/dh_gconf
+++ b/dh_gconf
@@ -22,19 +22,25 @@ It automatically generates the postinst and prerm fragments needed
to register and unregister the schemas in usr/share/gconf/schemas, using
gconf-schemas.
-If a file named debian/package.gconf-defaults exists, then it is
-installed into usr/share/gconf/defaults/10_package in the package build
-directory, with "package" replaced by the package name. Some postinst and
-postrm fragments will be generated to launch update-gconf-defaults.
-
-If a file named debian/package.gconf-mandatory exists, then it is
-installed into usr/share/gconf/mandatory/10_package in the package build
-directory, with "package" replaced by the package name, and similar
+An appropriate dependency on gconf2 will be generated in ${misc:Depends}.
+
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.gconf-defaults
+
+Installed into usr/share/gconf/defaults/10_package in the package build
+directory, with "I<package>" replaced by the package name. Some postinst
+and postrm fragments will be generated to run update-gconf-defaults.
+
+=item debian/I<package>.gconf-mandatory
+
+Installed into usr/share/gconf/mandatory/10_package in the package build
+directory, with "I<package>" replaced by the package name, and similar
postinst and postrm fragments will be generated.
-The gconf-schemas and update-gconf-defaults scripts are provided by the
-gconf2 package. An appropriate dependency will be generated in
-${misc:Depends}.
+=back
=head1 OPTIONS
diff --git a/dh_install b/dh_install
index 292837b4..875f80bf 100755
--- a/dh_install
+++ b/dh_install
@@ -24,15 +24,6 @@ those particular tasks. dh_install, then, is useful for installing everything
else, for which no particular intelligence is needed. It is a replacement for
the old dh_movefiles command.
-Files named debian/package.install list the files to install into each
-package and the directory they should be installed to. The format is a set
-of lines, where each line lists a file or files to install, and at the end
-of the line tells the directory it should be installed in. The name of the
-files (or directories) to install should be given relative to the current
-directory, while the installation directory is given relative to the
-package build directory. You may use wildcards in the names of the files to
-install (in v3 mode and above).
-
This program may be used in one of two ways. If you just have a file or two
that the upstream Makefile does not install for you, you can run dh_install
on them to move them into place. On the other hand, maybe you have a large
@@ -44,6 +35,22 @@ From debhelper compatibility level 7 on, dh_install will fall back to
looking in debian/tmp for files, if it doesn't find them in the current
directory (or whereever you've told it to look using --sourcedir).
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.install
+
+List the files to install into each package and the directory they should be
+installed to. The format is a set of lines, where each line lists a file or
+files to install, and at the end of the line tells the directory it should be
+installed in. The name of the files (or directories) to install should be given
+relative to the current directory, while the installation directory is given
+relative to the package build directory. You may use wildcards in the names of
+the files to install (in v3 mode and above).
+
+=back
+
=head1 OPTIONS
=over 4
diff --git a/dh_installcatalogs b/dh_installcatalogs
index 510a2bb3..f991a7c2 100755
--- a/dh_installcatalogs
+++ b/dh_installcatalogs
@@ -20,18 +20,11 @@ B<dh_installcatalogs> [S<I<debhelper options>>] [B<-n>]
dh_installcatalogs is a debhelper program that installs and
registers SGML catalogs. It complies with the Debian XML/SGML policy.
-The file F<debian/I<package>.sgmlcatalogs> contains the catalogs to be
-installed per package. Each line in that file should be of the form
-C<source dest>, where C<source> indicates where the catalog resides in
-the source tree, and C<dest> indicates the destination location for
-the catalog under the package build area. C<dest> should start with
-F</usr/share/sgml/>.
-
Catalogs will be registered in a supercatalog, in
F</etc/sgml/I<package>.cat>.
This command automatically adds maintainer script snippets for
-registering and unregistering the catalogs and "supercatalogs" (unless
+registering and unregistering the catalogs and supercatalogs (unless
B<-n> is used). These snippets are inserted into the maintainer scripts
by dh_installdeb; see L<dh_installdeb(1)> for an explanation of
Debhelper maintainer script snippets.
@@ -39,6 +32,20 @@ Debhelper maintainer script snippets.
A dependency on B<sgml-base> will be added to C<${misc:Depends}>, so be
sure your package uses that variable in F<debian/control>.
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.sgmlcatalogs
+
+Lists the catalogs to be installed per package. Each line in that file
+should be of the form C<source dest>, where C<source> indicates where the
+catalog resides in the source tree, and C<dest> indicates the destination
+location for the catalog under the package build area. C<dest> should
+start with F</usr/share/sgml/>.
+
+=back
+
=head1 OPTIONS
=over 4
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 3749d523..27e433c0 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -18,18 +18,6 @@ B<dh_installchangelogs> [S<I<debhelper options>>] [B<-k>] [B<-X>I<item>] [I<upst
dh_installchangelogs is a debhelper program that is responsible for
installing changelogs into package build directories.
-dh_installchangelogs determines if the package is a debian native package,
-and if so, it installs debian/changelog into usr/share/doc/package/changelog
-in the package build directory. Otherwise, it installs debian/changelog
-into usr/share/doc/package/changelog.Debian in the package build directory. (If
-files named debian/package.changelog exist, they will be used in preference
-to debian/changelog.)
-
-Parallelling the debian changelog handling, this program also takes care of
-NEWS.Debian files. If there is a debian/NEWS file, it is installed as
-usr/share/doc/package/NEWS.Debian. debian/package.NEWS files can also be
-used.
-
An upstream changelog file may be specified as an option. If none is
specified, a few common filenames are tried. (In compatibility level 7 and
above.)
@@ -41,6 +29,30 @@ installed as usr/share/doc/package/changelog.html instead, and will be
converted to plain text with html2text to generate
usr/share/doc/package/changelog.
+=head1 FILES
+
+=over 4
+
+=item debian/changelog
+
+=item debian/NEWS
+
+=item debian/I<package>.changelog
+
+=item debian/I<package>.NEWS
+
+Automatically installed into usr/share/doc/I<package>/
+in the package build directory.
+
+Use the package specific name if I<package> needs a different
+NEWS or changelog file.
+
+The changelog file is installed with a name of changelog
+for native packages, and changelog.Debian for non-native packages.
+The NEWS file is always installed with a name of NEWS.Debian.
+
+=back
+
=head1 OPTIONS
=over 4
diff --git a/dh_installcron b/dh_installcron
index 409b59ea..52248e6e 100755
--- a/dh_installcron
+++ b/dh_installcron
@@ -16,10 +16,26 @@ B<dh_installcron> [S<B<debhelper options>>] [B<--name=>I<name>]
=head1 DESCRIPTION
dh_installcron is a debhelper program that is responsible for installing
-cron scripts into etc/cron.*/ in package build directories. The files
-debian/package.cron.daily, debian/package.cron.weekly,
-debian/package.cron.monthly, debian/package.cron.hourly, and
-debian/package.cron.d are installed.
+cron scripts.
+
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.cron.daily
+
+=item debian/I<package>.cron.weekly
+
+=item debian/I<package>.cron.monthly
+
+=item debian/I<package>.cron.hourly
+
+=item debian/I<package>.cron.d
+
+Installed into the appropriate etc/cron.*/ directory in the package
+build directory.
+
+=back
=head1 OPTIONS
diff --git a/dh_installdeb b/dh_installdeb
index 93198ae5..386640b7 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -19,27 +19,38 @@ dh_installdeb is a debhelper program that is responsible for installing
files into the DEBIAN directories in package build directories with the
correct permissions.
-dh_installdeb automatically installs the following files from debian/ into
-the DEBIAN directory:
- package.postinst
- package.preinst
- package.postrm
- package.prerm
- package.shlibs
- package.conffiles
- package.triggers
-
-The postinst, preinst, postrm, and prerm are handled specially: If a
-corresponding file named debian/package.script.debhelper exists, the contents
-of that file are merged into the script as follows: If the script exists,
-then anywhere in it that "#DEBHELPER#" appears, the text of the .debhelper
-file is inserted. If the script does not exist, then a script is generated
-from the .debhelper file. The .debhelper files are created by other debhelper
-programs, such as L<dh_installmenu(1)>, and are shell script fragments.
+=head1 FILES
+
+=over 4
+
+=item I<package>.postinst
+
+=item I<package>.preinst
+
+=item I<package>.postrm
+
+=item I<package>.prerm
+
+These maintainer scripts are installed into the DEBIAN directory.
+
+Inside the scripts, the token B<#DEBHELPER#> is replaced with
+shell script snippets generated by other debhelper commands.
+
+=item I<package>.triggers
+
+=item I<package>.shlibs
+
+These control files are installed into the DEBIAN directory.
+
+=item I<package>.conffiles
+
+This control file will be installed into the DEBIAN directory.
In V3 compatibility mode and higher, all files in the etc/ directory in a
package will automatically be flagged as conffiles by this program, so
-there is no need to list them manually in package.conffiles.
+there is no need to list them manually here.
+
+=back
=cut
diff --git a/dh_installdebconf b/dh_installdebconf
index f12c7dad..ff49f8ea 100755
--- a/dh_installdebconf
+++ b/dh_installdebconf
@@ -16,36 +16,47 @@ B<dh_installdebconf> [S<I<debhelper options>>] [B<-n>] [S<B<--> I<params>>]
=head1 DESCRIPTION
dh_installdebconf is a debhelper program that is responsible for installing
-files used by the debconf package into package build directories.
+files used by debconf into package build directories.
It also automatically generates the postrm commands needed to interface
with debconf. The commands are added to the maintainer scripts by
dh_installdeb. See L<dh_installdeb(1)> for an explanation of how that
works.
-Files named debian/package.config and debian/package.templates are
-installed into the DEBIAN directory in the package build directory.
-If a file named debian/package.config.debhelper exists, the contents
-of that file are merged into the config script as follows: If the script
-exists, then anywhere in it that "#DEBHELPER#" appears, the text of the
-.debhelper file is inserted. If the script does not exist, then a script
-is generated from the .debhelper file. The .debhelper files may be created
-by other debhelper programs, and are shell script fragments.
-
Note that if you use debconf, your package probably needs to depend on it
(it will be added to ${misc:Depends} by this program).
Note that for your config script to be called by dpkg, your postinst
needs to source debconf's confmodule. dh_installdebconf does not
-install this statement into postinst automatically as it it too hard to
-do it right.
+install this statement into the postinst automatically as it it too
+hard to do it right.
+
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.config
+
+This is the debconf config script, and is installed into the DEBIAN
+directory in the package build directory.
-=head1 LOCALIZED TEMPLATE FILES
+Inside the script, the token B<#DEBHELPER#> is replaced with
+shell script snippets generated by other debhelper commands.
-This program will look to see if you have a debian/po directory and if so
-will automatically call L<po2debconf(1)> to generate a merged templates
-file containing the translations. For this to work, your package should
-build-depend on po-debconf.
+=item debian/I<package>.templates
+
+This is the debconf templates file, and is installed into the DEBIAN
+directory in the package build directory.
+
+=item debian/po/
+
+If this directory is present, this program will automatically use
+L<po2debconf(1)> to generate merged templates
+files that include the translations from there.
+
+For this to work, your package should build-depend on po-debconf.
+
+=back
=head1 OPTIONS
diff --git a/dh_installdirs b/dh_installdirs
index 7e9a1783..f48989ad 100755
--- a/dh_installdirs
+++ b/dh_installdirs
@@ -18,12 +18,15 @@ B<dh_installdirs> [S<I<debhelper options>>] [B<-A>] [S<I<dir ...>>]
dh_installdirs is a debhelper program that is responsible for creating
subdirectories in package build directories.
-A file named debian/package.dirs can list directories to be created.
+=head1 FILES
-Any directory names specified as parameters will be created in the package
-build directory of the first package dh_installdirs is told to act on. By
-default, this is the first binary package in debian/control, but if you use
--p, -i, or -a flags, it will be the first package specified by those flags.
+=over 4
+
+=item debian/I<package>.dirs
+
+Lists directories to be created in I<package>.
+
+=back
=head1 OPTIONS
diff --git a/dh_installdocs b/dh_installdocs
index 1226cf8f..465693bc 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -18,33 +18,44 @@ B<dh_installdocs> [S<I<debhelper options>>] [B<-A>] [B<-X>I<item>] [S<I<file ...
dh_installdocs is a debhelper program that is responsible for installing
documentation into usr/share/doc/package in package build directories.
-dh_installdocs automatically installs debian/copyright if it exists. If
-dh_installdocs is acting on multiple packages, debian/copyright files will be
-installed into all packages. However, if you need to have separate copyright
-files for different binary packages, you can use files named
-debian/package.copyright.
-
-Any filenames specified as parameters will be installed into the first
-package dh_installdocs is told to act on. By default, this is the first
-binary package in debian/control, but if you use B<-p>, B<-i>, or B<-a> flags, it
-will be the first package specified by those flags.
-
-Also, debian/README.Debian (or debian/README.debian) and debian/TODO, if
-they exist, will be installed into the first binary package listed in
-debian/control, if dh_installdocs is acting on that package. Note that
-debian/TODO will be installed named TODO.Debian, if the package is not a
-debian native package. Also note that README.debian is installed as
-README.Debian, for consistency. Note that debian/package.README.Debian and
-debian/package.TODO can be used to specify files for subpackages.
-
-Files named debian/package.docs can list other files to be installed.
-
-Files named debian/package.doc-base, will be installed as doc-base control
-files. Note that the doc-id will be determined from the "Document:" entry
-in the doc-base control file in question.
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.docs
+
+List documentaton files to be installed into I<package>.
+
+=item debian/copyright
+
+=item debian/README.Debian
+
+=item debian/TODO
+
+=item debian/I<package>.copyright
+
+=item debian/I<package>.README.Debian
+
+=item debian/I<package>.TODO
+
+Each of these files is automatically installed if present. Use the package
+specific name if I<package> needs a different version of the file.
+
+Note that debian/README.debian is also installed as README.Debian,
+and debian/TODO will be installed as TODO.Debian in non-native packages.
+
+=item debian/I<package>.doc-base
+
+Installed as doc-base control files. Note that the doc-id will be
+determined from the "Document:" entry in the doc-base control file in
+question.
+
+=item debian/I<package>.doc-base.*
If your package needs to register more than one document, you need multiple
-files. To accomplish this, you can use files named debian/package.doc-base.*
+doc-base files, and can name them like this.
+
+=back
=head1 OPTIONS
diff --git a/dh_installemacsen b/dh_installemacsen
index d8fa6574..08dd97a4 100755
--- a/dh_installemacsen
+++ b/dh_installemacsen
@@ -24,13 +24,26 @@ register a package as an emacs add on package. The commands are added to
the maintainer scripts by dh_installdeb. See L<dh_installdeb(1)>
for an explanation of how this works.
-If a file named debian/package.emacsen-install exists, then it is installed
-into
-usr/lib/emacsen-common/packages/install/package in the package build
-directory. Similarly, debian/package.emacsen-remove is installed into
-usr/lib/emacsen-common/packages/remove/package . And similarly,
-debian/package.emacsen-startup is installed into
-etc/emacs/site-start.d/50<package>.el (by default).
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.emacsen-install
+
+Installed into usr/lib/emacsen-common/packages/install/package in the
+package build directory.
+
+=item debian/I<package>.emacsen-remove
+
+Installed into usr/lib/emacsen-common/packages/remove/package in the
+package build directory.
+
+=item debian/I<package>.emacsen-startup
+
+Installed into etc/emacs/site-start.d/50I<package>.el in the package
+build directory. Use --priority to use a different priority than 50.
+
+=back
=head1 OPTIONS
diff --git a/dh_installexamples b/dh_installexamples
index 3e5e0893..d210f4f2 100755
--- a/dh_installexamples
+++ b/dh_installexamples
@@ -19,12 +19,15 @@ dh_installexamples is a debhelper program that is responsible for
installing examples into usr/share/doc/package/examples in package
build directories.
-Any file names specified as parameters will be installed into the first
-package dh_installexamples is told to act on. By default, this is the first
-binary package in debian/control, but if you use -p, -i, or -a flags, it
-will be the first package specified by those flags.
+=head1 OPTIONS
+
+=over 4
-Files named debian/package.examples can list other files to be installed.
+=item debian/I<package>.examples
+
+Lists example files or directories to be installed.
+
+=back
=head1 OPTIONS
@@ -35,16 +38,16 @@ Files named debian/package.examples can list other files to be installed.
Install any files specified by command line parameters in ALL packages
acted on.
-=item I<file ...>
-
-Install these files as examples into the first package acted on. (Or into
-all packages if -A is specified.)
-
=item B<-Xitem>, B<--exclude=item>
Exclude files that contain "item" anywhere in their filename from
being installed.
+=item I<file ...>
+
+Install these files (or directories) as examples into the first package
+acted on. (Or into all packages if -A is specified.)
+
=back
=head1 NOTES
diff --git a/dh_installifupdown b/dh_installifupdown
index 35e39eee..e394e3fa 100755
--- a/dh_installifupdown
+++ b/dh_installifupdown
@@ -19,9 +19,22 @@ dh_installifupdown is a debhelper program that is responsible for installing
if-up, if-down, if-pre-up, and if-post-down hook scripts into package build
directories.
-If a file named debian/package.if-up exists, then it is installed into
-etc/network/if-up.d/package in the package build directory. Similar is done
-for if-down, if-pre-up, and if-post-down.
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.if-up
+
+=item debian/I<package>.if-down
+
+=item debian/I<package>.if-pre-up
+
+=item debian/I<package>.if-post-down
+
+These files are installed into etc/network/if-*.d/I<package> in
+the package build directory.
+
+=back
=head1 OPTIONS
diff --git a/dh_installinfo b/dh_installinfo
index a7f5d914..6afe3407 100755
--- a/dh_installinfo
+++ b/dh_installinfo
@@ -18,12 +18,15 @@ B<dh_installinfo> [S<I<debhelper options>>] [B<-A>] [S<I<file ...>>]
dh_installinfo is a debhelper program that is responsible for installing
info files into usr/share/info in the package build directory.
-Any filenames specified as parameters will be installed into the first
-package dh_installinfo is told to act on. By default, this is the first
-binary package in debian/control, but if you use -p, -i, or -a flags, it
-will be the first package specified by those flags.
+=head1 FILES
-Files named debian/package.info can list other files to be installed.
+=over 4
+
+=item debian/I<package>.info
+
+List info files to be installed.
+
+=back
=head1 OPTIONS
diff --git a/dh_installinit b/dh_installinit
index f870e99d..7b1d2e20 100755
--- a/dh_installinit
+++ b/dh_installinit
@@ -24,17 +24,26 @@ It also automatically generates the postinst and postrm and prerm commands
needed to set up the symlinks in /etc/rc*.d/ and to start and stop the init
scripts.
-If a file named debian/package.upstart exists, then it is installed into
-etc/init/package.conf in the package build directory, with "package" replaced
-by the package name.
+=head1 FILES
-Otherwise, if a file named debian/package.init exists, then it is installed
-into etc/init.d/package in the package build directory, with "package"
-replaced by the package name.
+=over 4
+
+=item debian/I<package>.upstart
+
+If this exists, it is installed into etc/init/I<package>.conf in the package
+build directory.
+
+=item debian/I<package>.init
-If a file named debian/package.default exists, then it is installed into
-etc/default/package in the package build directory, with "package" replaced
-by the package name.
+Otherwise, if this exists, it is installed
+into etc/init.d/I<package> in the package build directory.
+
+=item debian/I<package>.default
+
+If this exists, it is installed into etc/default/I<package> in the package
+build directory.
+
+=back
=head1 OPTIONS
diff --git a/dh_installlogcheck b/dh_installlogcheck
index 1f352de7..4b9a42dd 100755
--- a/dh_installlogcheck
+++ b/dh_installlogcheck
@@ -16,13 +16,26 @@ B<dh_installlogcheck> [S<B<debhelper options>>]
=head1 DESCRIPTION
dh_installlogcheck is a debhelper program that is responsible for
-installing logcheck rule files into subdirectories of etc/logcheck/ in
-package build directories. The files debian/package.logcheck.cracking,
-debian/package.logcheck.violations,
-debian/package.logcheck.violations.ignore,
-debian/package.logcheck.ignore.workstation,
-debian/package.logcheck.ignore.server and
-debian/package.logcheck.ignore.paranoid are installed if present.
+installing logcheck rule files.
+
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.logcheck.cracking
+
+=item debian/I<package>.logcheck.violations
+
+=item debian/I<package>.logcheck.violations.ignore
+
+=item debian/I<package>.logcheck.ignore.workstation
+
+=item debian/I<package>.logcheck.ignore.server
+
+=item debian/I<package>.logcheck.ignore.paranoid
+
+Each of these files, if present, are installed into corresponding
+subdirectories of etc/logcheck/ in package build directories.
=cut
diff --git a/dh_installman b/dh_installman
index a167cc3a..30168cb2 100755
--- a/dh_installman
+++ b/dh_installman
@@ -38,14 +38,6 @@ like /usr/share/man/pl/man1/, that is because your program has a
name like "foo.pl", and dh_installman assumes that means it is translated
into Polish. Use --language=C to avoid this.
-Any man page filenames specified as parameters will be installed into the
-first package dh_installman is told to act on. By default, this is the
-first binary package in debian/control, but if you use -p, -i, or -a flags,
-it will be the first package specified by those flags.
-
-Files named debian/package.manpages can list other man pages to be
-installed.
-
After the man page installation step, dh_installman will check to see if
any of the man pages in the temporary directories of any of the packages it
is acting on contain ".so" links. If so, it changes them to symlinks.
@@ -55,6 +47,14 @@ manual page and convert it to UTF-8. If the guesswork fails for some
reason, you can override it using an encoding declaration. See
L<manconv(1)> for details.
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.manpages
+
+Lists man pages to be installed.
+
=head1 OPTIONS
=over 4
diff --git a/dh_installmenu b/dh_installmenu
index 327fac0f..c1a609a9 100755
--- a/dh_installmenu
+++ b/dh_installmenu
@@ -20,16 +20,23 @@ files used by the debian menu package into package build directories.
It also automatically generates the postinst and postrm commands needed to
interface with the debian menu package. These commands are inserted into
-the maintainer scripts by dh_installdeb. See L<dh_installdeb(1)> for an
-explanation of how this works.
+the maintainer scripts by L<dh_installdeb(1)>.
-If a file named debian/package.menu exists, then it is installed into
-usr/share/menu/package in the package build directory. This is a debian menu
-file. See L<menufile(5)> for its format.
+=head1 FILES
-If a file named debian/package.menu-method exits, then it is installed into
-etc/menu-methods/package in the package build directory. This is a debian
-menu method file.
+=over 4
+
+=item debian/I<package>.menu
+
+Debian menu files, installed into usr/share/menu/I<package> in the package
+build directory. See L<menufile(5)> for its format.
+
+=item debian/I<package>.menu-method
+
+Debian menu method files, installed into etc/menu-methods/I<package>
+in the package build directory.
+
+=back
=head1 OPTIONS
diff --git a/dh_installmime b/dh_installmime
index 18abe162..6886975e 100755
--- a/dh_installmime
+++ b/dh_installmime
@@ -20,14 +20,24 @@ mime files into package build directories.
It also automatically generates the postinst and postrm commands needed to
interface with the debian mime-support and shared-mime-info packages. These
-commands are inserted into the maintainer scripts by dh_installdeb. See
-L<dh_installdeb(1)> for an explanation of how this works.
+commands are inserted into the maintainer scripts by L<dh_installdeb(1)>.
-If files named debian/package.mime or debian/package.sharedmimeinfo exist, then
-they are installed into usr/lib/mime/packages/package and
-/usr/share/mime/packages/package.xml (respectively) in the package build
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.mime
+
+Installed into usr/lib/mime/packages/I<package> in the package build
directory.
+=item debian/I<package>.sharedmimeinfo
+
+Installed into /usr/share/mime/packages/I<package>.xml in the package build
+directory.
+
+=back
+
=head1 OPTIONS
=over 4
diff --git a/dh_installmodules b/dh_installmodules
index 475d8388..6799a122 100755
--- a/dh_installmodules
+++ b/dh_installmodules
@@ -20,25 +20,26 @@ B<dh_installmodules> [S<I<debhelper options>>] [B<-n>] [B<--name=>I<name>]
dh_installmodules is a debhelper program that is responsible for
registering kernel modules.
-Files named debian/package.modprobe will be installed in
-etc/modprobe.d/package.conf in the package build directory, to be used by
-module-init-tools's version of modprobe.
-
Kernel modules are searched for in the package build directory and if
found, postinst and postrm commands are automatically generated to
run depmod and register the modules when the package is installed.
-These commands are inserted into the maintainer scripts by dh_installdeb.
-See L<dh_installdeb(1)> for an explanation of how this works.
+These commands are inserted into the maintainer scripts by
+L<dh_installdeb(1)>.
+
+=head1 FILES
+
+=over 4
-Previous versions of dh_installmodules installed files named
-etc/modprobe.d/package, code is added to the preinst and postinst to
-handle the upgrade from the old location.
+=item debian/I<package>.modprobe
-Previous versions of dh_installmodules also supported
-files named debian/package.modules, which were installed into
-etc/modutils/package in the package build directory. This was for use by
-modutils, which is no longer in Debian. dh_installmodules will warn about
-such files now.
+Installed to etc/modprobe.d/I<package>.conf in the package build directory.
+
+=item debian/I<package>.modules
+
+These files were installed for use by modutils, but are now not used
+and dh_installmodules will warn if these files are present.
+
+=back
=head1 OPTIONS
@@ -51,9 +52,8 @@ Do not modify postinst/postrm scripts.
=item B<--name=>I<name>
When this parameter is used, dh_installmodules looks for and
-installs files named debian/package.name.modules and
-debian/package.name.modprobe instead of the usual
-debian/package.modules and debian/package.modprobe
+installs files named debian/I<package>.I<name>.modprobe instead
+of the usual debian/I<package>.modprobe
=back
diff --git a/dh_installpam b/dh_installpam
index 68678f87..90e31b2f 100755
--- a/dh_installpam
+++ b/dh_installpam
@@ -18,8 +18,15 @@ B<dh_installpam> [S<I<debhelper options>>] [B<--name=>I<name>]
dh_installpam is a debhelper program that is responsible for installing
files used by PAM into package build directories.
-If a file named debian/package.pam exists, then it is installed into
-etc/pam.d/package in the package build directory.
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.pam
+
+Installed into etc/pam.d/I<package> in the package build directory.
+
+=back
=head1 OPTIONS
@@ -27,9 +34,9 @@ etc/pam.d/package in the package build directory.
=item B<--name=>I<name>
-Look for files named debian/package.name.pam and install them as
-etc/pam.d/name, instead of using the usual files and installing them as
-the package name.
+Look for files named debian/I<package>.I<name>.pam and install them as
+etc/pam.d/I<name>, instead of using the usual files and installing them
+using the package name.
=back
diff --git a/dh_installppp b/dh_installppp
index 950470f3..60c5cccd 100755
--- a/dh_installppp
+++ b/dh_installppp
@@ -16,12 +16,21 @@ B<dh_installppp> [S<I<debhelper options>>] [B<--name=>I<name>]
=head1 DESCRIPTION
dh_installppp is a debhelper program that is responsible for installing
-ppp ip-up and ip-down scripts. into package build directories.
+ppp ip-up and ip-down scripts into package build directories.
-If a file named debian/package.ppp.ip-up exists, then it is installed into
-etc/ppp/ip-up.d/package in the package build directory.
-Files named debian/package.ppp.ip-down are installed to
-etc/ppp/ip-down.d/package
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.ppp.ip-up
+
+Installed into etc/ppp/ip-up.d/I<package> in the package build directory.
+
+=item debian/I<package>.ppp.ip-down
+
+Installed into etc/ppp/ip-down.d/I<package> in the package build directory.
+
+=back
=head1 OPTIONS
diff --git a/dh_installudev b/dh_installudev
index 0d38cf56..7193ebd4 100755
--- a/dh_installudev
+++ b/dh_installudev
@@ -19,12 +19,19 @@ B<dh_installudev> [S<I<debhelper options>>] [B<-n>] [B<--name=>I<name>] [B<--pri
dh_installudev is a debhelper program that is responsible for
installing udev rules files.
-Files named debian/package.udev will be installed in
-lib/udev/rules.d/ in the package build directory.
-
Code is added to the preinst and postinst to handle the upgrade from the
old udev rules file location.
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.udev
+
+Installed into lib/udev/rules.d/ in the package build directory.
+
+=back
+
=head1 OPTIONS
=over 4
@@ -32,8 +39,8 @@ old udev rules file location.
=item B<--name=>I<name>
When this parameter is used, dh_installudev looks for and
-installs files named debian/package.name.udev instead of the usual
-debian/package.udev.
+installs files named debian/I<package>.I<name>.udev instead of the usual
+debian/I<package>.udev.
=item B<--priority=>I<priority>
diff --git a/dh_installwm b/dh_installwm
index e07b7299..43f561d1 100755
--- a/dh_installwm
+++ b/dh_installwm
@@ -21,13 +21,15 @@ with L<update-alternatives(8)>. The window manager's man page is also
registered as a slave symlink (in v6 mode and up), if it is found in
usr/share/man/man1/ in the package build directory.
-Any window manager programs specified as parameters will be registered in
-the first package dh_installwm is told to act on. By default, this is the
-first binary package in debian/control, but if you use -p, -i, or -a flags,
-it will be the first package specified by those flags.
+=head1 FILES
-Files named debian/package.wm can list other window manager programs to
-register.
+=over 4
+
+=item debian/I<package>.wm
+
+List window manager programs to register.
+
+=back
=head1 OPTIONS
@@ -45,8 +47,7 @@ Do not modify postinst/postrm scripts. Turns this command into a no-op.
=item I<wm ...>
-The commands used to run the window manager or window managers you want to
-register.
+Window manager programs to register.
=back
diff --git a/dh_link b/dh_link
index dc396dd5..35f43717 100755
--- a/dh_link
+++ b/dh_link
@@ -24,15 +24,6 @@ files are the already existing files that will be symlinked from. The
destination files are the symlinks that will be created. There B<must> be
an equal number of source and destination files specified.
-The list can be specified in two ways. A file named debian/package.links
-can list pairs of files. If you use this file, you should put each pair
-of files on its own line, and separate the files within the pair with
-whitespace. Also, pairs of files can be specified as parameters - these
-pairs will only be created in the package build directory of the first
-package dh_link is told to act on. By default, this is the first binary
-package in debian/control, but if you use -p, -i, or -a flags, it will be
-the first package specified by those flags.
-
Be sure you B<do> specify the full filename to both the source and
destination files (unlike you would do if you were using something like
L<ln(1)>).
@@ -45,6 +36,16 @@ the symlinks in.
dh_link also scans the package build tree for existing symlinks which do not
conform to debian policy, and corrects them (v4 or later).
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.links
+
+Lists pairs of source and destination files to be symlinked. Each pair
+should be put on its own line, with the source and destination separated by
+whitespace.
+
=head1 OPTIONS
=over 4
diff --git a/dh_lintian b/dh_lintian
index 0dcf60be..4e773730 100755
--- a/dh_lintian
+++ b/dh_lintian
@@ -18,14 +18,22 @@ B<dh_lintian> [S<I<debhelper options>>]
dh_lintian is a debhelper program that is responsible for installing
override files used by lintian into package build directories.
-If a file named debian/package.lintian-overrides exists, then it is
-installed into usr/share/lintian/overrides/package in the package
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.lintian-overrides
+
+Installed into usr/share/lintian/overrides/I<package> in the package
build directory. This file is used to suppress erroneous lintian
diagnostics.
-Note that a file named debian/source.lintian-overrides will not be
-installed, but will be scanned by lintian to provide overrides for the
-source package.
+=item debian/I<source>.lintian-overrides
+
+These files are not installed, but will be scanned by lintian to provide
+overrides for the source package.
+
+=back
=cut
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 776e66f0..03a54f95 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -21,9 +21,19 @@ libraries, and generates a shlibs file for the libraries it finds.
It also adds a call to ldconfig in the postinst and postrm scripts (in
V3 mode and above only) to any packages in which it finds shared libraries.
-If a L<dpkg-gensymbols(1)> symbol file is found in debian/package.symbols
-(or debian/package.symbols.arch), dpkg-gensymbols will be called
-to process and install the symbols file.
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.symbols
+
+=item debian/I<package>.symbols.I<arch>
+
+These symbols files, if present, are passed to L<dpkg-gensymbols(1)> to
+be processed and installed. Use the I<arch> specific names if you need
+to provide different symbols files for different architectures.
+
+=back
=head1 OPTIONS
diff --git a/dh_movefiles b/dh_movefiles
index 5e1db0fc..03957a03 100755
--- a/dh_movefiles
+++ b/dh_movefiles
@@ -20,15 +20,21 @@ out of debian/tmp or some other directory and into other package build
directories. This may be useful if your package has a Makefile that installs
everything into debian/tmp, and you need to break that up into subpackages.
-Files named debian/package.files list the files to be moved, separated by
-whitespace. The filenames listed should be relative to debian/tmp/. You can
-also list directory names, and the whole directory will be moved. If you
-prefer, you can list the files to move on the command line and this will
-apply to the first package dh_movefiles is told to act on.
-
Note: dh_install is a much better program, and you are recommended to use
it instead of dh_movefiles.
+=head1 FILES
+
+=over 4
+
+=item debian/I<package>.files
+
+Lists the files to be moved into a package, separated by whitespace. The
+filenames listed should be relative to debian/tmp/. You can also list
+directory names, and the whole directory will be moved.
+
+=back
+
=head1 OPTIONS
=over 4