summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_install3
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b68e6d24..fda83527 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -47,6 +47,14 @@ debhelper (7.3.0) experimental; urgency=low
-- Joey Hess <joeyh@debian.org> Wed, 01 Jul 2009 15:31:20 -0400
+debhelper (7.2.22) unstable; urgency=low
+
+ * dh_install: Fix support for the case where --sourcedir=debian/tmp/foo
+ is used. Perl was not being greedy enough and the 'foo' was not stripped
+ from the destination directory in this unusual case. Closes: #537017
+
+ -- Joey Hess <joeyh@debian.org> Tue, 14 Jul 2009 17:08:25 -0400
+
debhelper (7.2.21) unstable; urgency=low
* Add a versioned dep on perl-base, to get a version that supports
diff --git a/dh_install b/dh_install
index c5647c6b..a8e08c2a 100755
--- a/dh_install
+++ b/dh_install
@@ -170,7 +170,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (! defined $dest) {
# Guess at destination directory.
$dest=$src;
- $dest=~s/^(.*\/)?(\Q$srcdir\E|debian\/tmp)\///;
+ $dest=~s/^(.*\/)?\Q$srcdir\E\/// ||
+ $dest=~s/^(.*\/)?debian\/tmp\///;
$dest=dirname("/".$dest);
$tmpdest=1;
}