summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdh7
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6ebb4d0d..d99968f0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,9 @@ debhelper (8.9.10) UNRELEASED; urgency=low
Needs a new enough binutils and gdb; debhelper backport
may need to disable this.
Thanks, Aurelien Jarno and Bastien ROUCARIES. Closes: #631985
+ * dh: Ensure -a and -i are passed when running override_dh_command-arch
+ and override_dh_command-indep targets. This is needed when the binary
+ target is run, rather than binary-arch/binary-indep. Closes: #648901
-- Joey Hess <joeyh@debian.org> Mon, 07 Nov 2011 13:50:30 -0400
diff --git a/dh b/dh
index 4eae4448..27733acc 100755
--- a/dh
+++ b/dh
@@ -726,6 +726,13 @@ sub run_override {
return @rest if ! $has_explicit_target; # has empty override
return @rest unless @todo; # has override, but no packages to act on
+ if (defined $override_type) {
+ # Ensure appropriate -a or -i option is passed when running
+ # an arch-specific override target.
+ my $opt=$override_type eq "arch" ? "-a" : "-i";
+ push @options, $opt unless grep { $_ eq $opt } @options;
+ }
+
# This passes the options through to commands called
# inside the target.
$ENV{DH_INTERNAL_OPTIONS}=join("\x1e", @options);