summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdh_python2
2 files changed, 4 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index bd24cb4b..902c451f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,10 @@
debhelper (4.1.45) unstable; urgency=low
-UNRE
* Typo fixes from Adam Garside.
+ * dh_python: don't bother terminating the regexp, 2.2.3c1 for example.
+ Closes: #194531
- -- Joey Hess <joeyh@debian.org> Thu, 22 May 2003 21:28:17 -0400
+ -- Joey Hess <joeyh@debian.org> Sat, 24 May 2003 11:55:32 -0400
debhelper (4.1.44) unstable; urgency=low
diff --git a/dh_python b/dh_python
index 3a001bd4..d936f318 100755
--- a/dh_python
+++ b/dh_python
@@ -67,7 +67,7 @@ my $python_version = `$python -V 2>&1`;
if ("$python_version" eq "") {
error("Python is not installed, aborting. (Probably forgot to Build-Depend on python.)");
}
-elsif ($python_version =~ m/^Python\s+(\d+)\.(\d+)\.\d+\+?\n$/) {
+elsif ($python_version =~ m/^Python\s+(\d+)\.(\d+)\.\d+/) {
$python_version = "$1.$2" ;
$python_major = $1 ;
} else {