summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh3
2 files changed, 5 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index d634f5a6..4da5f488 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
debhelper (8.9.7) UNRELEASED; urgency=low
+ * dh: Don't bother running dh_shlibdebs, dh_makeshelibs, or dh_strip
+ for the binary target when all packages being acted on are indep.
* debhelper no longer build-depends on man-db, to ease bootstrapping.
-- Joey Hess <joeyh@debian.org> Mon, 29 Aug 2011 20:18:01 -0400
diff --git a/dh b/dh
index c66d987b..b86e36ad 100755
--- a/dh
+++ b/dh
@@ -422,6 +422,9 @@ my @ba=qw{
dh_makeshlibs
dh_shlibdeps
};
+if (! getpackages("arch")) {
+ @ba=();
+}
my @b=qw{
dh_installdeb
dh_gencontrol