summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installchangelogs1
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7e6e5cc3..7fac7623 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (9.20130605) UNRELEASED; urgency=low
+
+ * dh_installchangelogs: Fix bug preventing automatic installation of
+ upstream changelog. Closes: #711131
+
+ -- Joey Hess <joeyh@debian.org> Wed, 05 Jun 2013 12:28:19 -0400
+
debhelper (9.20130604) unstable; urgency=low
* dh_installchangelogs: No longer automatically converts html changelogs.
diff --git a/dh_installchangelogs b/dh_installchangelogs
index d1e79492..74745720 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -148,6 +148,7 @@ if (! defined $upstream) {
} @files;
if (@matches) {
$upstream=shift @matches;
+ $upstream_text=$upstream;
last;
}
}