summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installman2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f3c788c9..04c22653 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.21) unstable; urgency=low
+
+ * dh_installman: correct mistake that broke translated man page installation
+ Closes: #349995
+
+ -- Joey Hess <joeyh@debian.org> Thu, 26 Jan 2006 12:32:44 -0500
+
debhelper (5.0.20) unstable; urgency=low
* Minor bug fix from last release.
diff --git a/dh_installman b/dh_installman
index f054796c..6544eae4 100755
--- a/dh_installman
+++ b/dh_installman
@@ -143,7 +143,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $destdir="$tmp/usr/share/man/man$realsection/";
my $langcode;
- if (! exists $dh{LANGUAGE}) {
+ if (! defined $dh{LANGUAGE} || ! exists $dh{LANGUAGE}) {
# Translated man pages are typically specified by adding the
# language code to the filename, so detect that and
# redirect to appropriate directory, stripping the code.