summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Getopt.pm3
-rw-r--r--debian/changelog10
-rw-r--r--man/po4a/po/debhelper.pot2
3 files changed, 13 insertions, 2 deletions
diff --git a/Debian/Debhelper/Dh_Getopt.pm b/Debian/Debhelper/Dh_Getopt.pm
index aecac14d..27f0cc0e 100644
--- a/Debian/Debhelper/Dh_Getopt.pm
+++ b/Debian/Debhelper/Dh_Getopt.pm
@@ -190,7 +190,8 @@ sub parseopts {
if ($options{DOINDEP} || $options{DOARCH} || $options{DOSAME}) {
# User specified that all arch (in)dep package be
# built, and there are none of that type.
- error("I have no package to build");
+ warning("I have no package to build");
+ exit(0);
}
push @{$options{DOPACKAGES}},getpackages();
}
diff --git a/debian/changelog b/debian/changelog
index 86778cd9..f809e8bd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+debhelper (5.0.30) unstable; urgency=low
+
+ * Convert the "I have no packages to build" error into a warning. Am I
+ really the first person to run into the case of a source package that
+ builds an arch all package and an single-arch package? In this case,
+ the binary-arch target needs to use -s and do nothing when run on some
+ other arch, and debhelper will now support this.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 14 Apr 2006 00:35:55 +0200
+
debhelper (5.0.29) unstable; urgency=low
* dh_installxfonts: Random hack to deal with X font dirs moving to
diff --git a/man/po4a/po/debhelper.pot b/man/po4a/po/debhelper.pot
index 77186662..c94d0049 100644
--- a/man/po4a/po/debhelper.pot
+++ b/man/po4a/po/debhelper.pot
@@ -6,7 +6,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2006-04-13 10:56+0200\n"
+"POT-Creation-Date: 2006-04-14 0:39+0200\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"