summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/autoconf.pm10
-rw-r--r--debian/changelog3
2 files changed, 12 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/autoconf.pm b/Debian/Debhelper/Buildsystem/autoconf.pm
index 7229fc71..59b6c6b2 100644
--- a/Debian/Debhelper/Buildsystem/autoconf.pm
+++ b/Debian/Debhelper/Buildsystem/autoconf.pm
@@ -49,7 +49,15 @@ sub configure {
}
$this->mkdir_builddir();
- $this->doit_in_builddir($this->get_source_rel2builddir("configure"), @opts, @_);
+ eval {
+ $this->doit_in_builddir($this->get_source_rel2builddir("configure"), @opts, @_);
+ };
+ if ($@) {
+ if (-e $this->get_buildpath("config.log")) {
+ $this->doit_in_builddir("cat config.log");
+ }
+ die $@;
+ }
}
1
diff --git a/debian/changelog b/debian/changelog
index 05b5b80b..6b8ea919 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -23,6 +23,9 @@ debhelper (7.4.4) UNRELEASED; urgency=low
* Typo. Closes: #555659
* cmake: Set CTEST_OUTPUT_ON_FAILURE when running test suite.
Closes: #555807
+ * autoconf: If configure fails, cat config.log. Intended to make
+ it easier to debug configure script failures on autobuilders.
+ Closes: #556384
-- Joey Hess <joeyh@debian.org> Wed, 28 Oct 2009 18:10:45 -0400