summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_makeshlibs2
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c43333ae..54c6a391 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (2.2.2) unstable; urgency=low
+
+ * dh_makeshlibs: corrected the evil db3-regex so it doesn't misfire on
+ data like "debian/libruby/usr/lib/ruby/1.6/i486-linux/etc.so".
+ Closes: #78139
+
+ -- Joey Hess <joeyh@debian.org> Mon, 27 Nov 2000 12:21:53 -0800
+
debhelper (2.2.1) unstable; urgency=low
* Reverted the change to make debian/README be treated as README.Debian,
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 1b50ea11..8f3e7a7a 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -19,7 +19,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
$need_ldconfig=1;
# The second evil regexp is for db3, whose author should
# be shot.
- if (m#.*/(.*)\.so\.(\d*)\.?# || m#.*/(.*)-(\S+)\.so$#) {
+ if (m#.*/([^/]*)\.so\.(\d*)\.?# || m#.*/([^/]*)-([^\s/]+)\.so$#) {
$library = $1;
$major = $2;
}