summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm12
-rw-r--r--debian/changelog9
2 files changed, 21 insertions, 0 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index a5b27d6d..9468e38f 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -82,7 +82,19 @@ sub pre_building_step {
sub setup_py {
my $this=shift;
my $act=shift;
+ my $python_default = `pyversions -d`;
+ $python_default =~ s/^\s+//;
+ $python_default =~ s/\s+$//;
+
+ # We need to to run setup.py with the default python first
+ # as distutils/setuptools modifies the shebang lines of scripts.
+ # This ensures that #!/usr/bin/python is used and not pythonX.Y
$this->doit_in_sourcedir("python", "setup.py", $act, @_);
+ for my $python (grep(!/^$python_default/, (split ' ', `pyversions -r 2>/dev/null`))) {
+ if (-x "/usr/bin/" . $python) {
+ $this->doit_in_sourcedir($python, "setup.py", $act, @_);
+ }
+ }
}
sub build {
diff --git a/debian/changelog b/debian/changelog
index ac78030d..8e70d28f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (7.3.5) experimental; urgency=low
+
+ * python_distutils buildsystem: Build for all supported Python
+ versions in case they're installed. Ensure that correct
+ shebangs are created by using `python' first during build
+ and install. Closes: #520834
+
+ -- Bernd Zeimetz <bzed@debian.org> Sun, 19 Jul 2009 03:45:23 +0200
+
debhelper (7.3.4) experimental; urgency=low
* Merged debhelper 7.2.24.