summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_install6
2 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index dfb817c5..b22aa719 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.0.2) unstable; urgency=low
+
+ * dh_install: delay globbing until after destintations have been found.
+ Closes: #143234
+
+ -- Joey Hess <joeyh@debian.org> Tue, 16 Apr 2002 21:25:32 -0400
+
debhelper (4.0.1) unstable; urgency=low
* dh_installdebconf: allow parameters after -- to go to
diff --git a/dh_install b/dh_install
index b3dab4c1..019d0f1b 100755
--- a/dh_install
+++ b/dh_install
@@ -30,7 +30,7 @@ the line tells the directory it should be installed in. The name of the
files (or directories) to install should be given relative to the current
directory, while the installation directory is given relative to the
package build directory. You may use wildcards in the names of the files to
-install.
+install (in v3 mode and above).
This program may be used in one of two ways. If you just have a file or two
that the upstream Makefile does not install for you, you can run dh_install
@@ -84,7 +84,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my @install;
if ($file) {
- @install=filedoublearray($file, ".");
+ @install=filedoublearray($file); # no globbing yet
}
if (($package eq $dh{FIRSTPACKAGE} || $dh{PARAMS_ALL}) && @ARGV) {
@@ -104,7 +104,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$dest=pop @$set;
}
- foreach my $src (@$set) {
+ foreach my $src (map { glob } @$set) { # glob now
next if excludefile($src);
if (! defined $dest) {