summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdh_auto_test6
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6d32da53..ae852e3e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -29,6 +29,7 @@ debhelper (9.20120609) UNRELEASED; urgency=low
by instead using -perm /mode. Closes: #700200
* cmake: Configure with -DCMAKE_BUILD_TYPE=RelWithDebInfo
Closes: #701233
+ * dh_auto_test: Avoid doing anything when cross-compiling. Closes: #703262
-- Joey Hess <joeyh@debian.org> Thu, 05 Jul 2012 08:51:07 -0600
diff --git a/dh_auto_test b/dh_auto_test
index 9d3fd93c..01dc5df5 100755
--- a/dh_auto_test
+++ b/dh_auto_test
@@ -47,9 +47,13 @@ B<dh_auto_test> usually passes.
If the B<DEB_BUILD_OPTIONS> environment variable contains B<nocheck>, no
tests will be performed.
+dh_auto_test does not run the test suite when a package is being cross
+compiled.
+
=cut
-if (get_buildoption("nocheck")) {
+if (get_buildoption("nocheck")
+ || (dpkg_architecture_value("DEB_HOST_GNU_TYPE") ne dpkg_architecture_value("DEB_BUILD_GNU_TYPE"))) {
exit 0;
}