summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-python12
-rw-r--r--debian/changelog8
-rwxr-xr-xexamples/rules4
-rwxr-xr-xexamples/rules.indep2
-rwxr-xr-xexamples/rules.multi6
-rwxr-xr-xexamples/rules.multi24
6 files changed, 23 insertions, 13 deletions
diff --git a/autoscripts/postinst-python b/autoscripts/postinst-python
index 2ecb99b2..6f1f9a5b 100644
--- a/autoscripts/postinst-python
+++ b/autoscripts/postinst-python
@@ -1,6 +1,8 @@
PYTHON=#PYVER#
-DIRLIST="#DIRLIST#"
-for i in $DIRLIST ; do
- $PYTHON -O /usr/lib/$PYTHON/compileall.py -q $i
- $PYTHON /usr/lib/$PYTHON/compileall.py -q $i
-done
+if which $PYTHON >/dev/null 2>&1; then
+ DIRLIST="#DIRLIST#"
+ for i in $DIRLIST ; do
+ $PYTHON -O /usr/lib/$PYTHON/compileall.py -q $i
+ $PYTHON /usr/lib/$PYTHON/compileall.py -q $i
+ done
+fi
diff --git a/debian/changelog b/debian/changelog
index 54693a67..b267d9e3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.27) unstable; urgency=low
+
+ * Fixed dh_python ordering in example rules files. Closes: #172283
+ * Make python postinst fragment only run python if it is installed, useful
+ for packages that include python modules but do not depend on python.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 9 Dec 2002 12:12:31 -0500
+
debhelper (4.1.26) unstable; urgency=low
* dh_builddeb: Reluctantly call dpkg-deb directly. dpkg cannot pass extra
diff --git a/examples/rules b/examples/rules
index 4f2b7ace..aead2db1 100755
--- a/examples/rules
+++ b/examples/rules
@@ -61,10 +61,10 @@ binary-arch: build install
dh_strip
dh_compress
dh_fixperms
-# dh_makeshlibs
- dh_installdeb
# dh_perl
# dh_python
+# dh_makeshlibs
+ dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
diff --git a/examples/rules.indep b/examples/rules.indep
index 50496f94..4ffa6da9 100755
--- a/examples/rules.indep
+++ b/examples/rules.indep
@@ -58,9 +58,9 @@ binary-indep: build install
dh_link
dh_compress
dh_fixperms
- dh_installdeb
# dh_perl
# dh_python
+ dh_installdeb
dh_gencontrol
dh_md5sums
dh_builddeb
diff --git a/examples/rules.multi b/examples/rules.multi
index 17a0d348..b41387b3 100755
--- a/examples/rules.multi
+++ b/examples/rules.multi
@@ -62,9 +62,9 @@ binary-indep: build install
dh_link -i
dh_compress -i
dh_fixperms -i
- dh_installdeb -i
# dh_perl -i
# dh_python -i
+ dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
@@ -91,10 +91,10 @@ binary-arch: build install
dh_link -a
dh_compress -a
dh_fixperms -a
-# dh_makeshlibs -a
- dh_installdeb -a
# dh_perl -a
# dh_python -a
+# dh_makeshlibs -a
+ dh_installdeb -a
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a
diff --git a/examples/rules.multi2 b/examples/rules.multi2
index 36f921b4..8c9f3a3f 100755
--- a/examples/rules.multi2
+++ b/examples/rules.multi2
@@ -68,10 +68,10 @@ binary-common:
dh_link
dh_compress
dh_fixperms
-# dh_makeshlibs
- dh_installdeb
# dh_perl
# dh_python
+# dh_makeshlibs
+ dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums