summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules1
-rw-r--r--t/syntax11
3 files changed, 19 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5b2ddd57..b575957e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (5.0.3) UNRELEASED; urgency=low
+
+ * Remove dh_shlibs from binary-indep section of debian/rules.
+ * Add t/syntax to make sure all dh_* commands and the libraries syntax check
+ ok.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 7 Nov 2005 15:17:09 -0500
+
debhelper (5.0.2) unstable; urgency=low
* Sometimes it's a good idea to edit more files than just the changelog
diff --git a/debian/rules b/debian/rules
index 4029f209..0457356a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -80,7 +80,6 @@ binary-indep: build
./run dh_installexamples examples/*
./run dh_installman *.1 *.7
./run dh_installchangelogs
- ./run dh_shlibdeps
./run dh_link
./run dh_compress
./run dh_fixperms
diff --git a/t/syntax b/t/syntax
new file mode 100644
index 00000000..b647b915
--- /dev/null
+++ b/t/syntax
@@ -0,0 +1,11 @@
+#!/usr/bin/perl
+use Test;
+
+my @progs=grep { -x $_ } glob("dh_*");
+my @libs=glob("Debian/Debhelper/*.pm");
+
+plan(tests => (@progs + @libs));
+
+foreach my $file (@progs, @libs) {
+ ok(system("perl -c $file >/dev/null 2>&1"), 0);
+}