summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Getopt.pm6
-rw-r--r--Debian/Debhelper/Dh_Lib.pm8
-rw-r--r--debhelper.15
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_gencontrol5
-rwxr-xr-xdh_testdir2
6 files changed, 15 insertions, 18 deletions
diff --git a/Debian/Debhelper/Dh_Getopt.pm b/Debian/Debhelper/Dh_Getopt.pm
index 18157bf0..6d545e36 100644
--- a/Debian/Debhelper/Dh_Getopt.pm
+++ b/Debian/Debhelper/Dh_Getopt.pm
@@ -148,9 +148,9 @@ sub parseopts {
# packages out, below.
if (! defined $options{DOPACKAGES} || ! @{$options{DOPACKAGES}}) {
if ($options{DOINDEP} || $options{DOARCH} || $options{DOSAME}) {
- # User specified that all arch (in)dep package be
- # built, and there are none of that type.
- error("I have no package to build");
+ # User specified that all arch (in)dep package be
+ # built, and there are none of that type.
+ error("I have no package to build");
}
push @{$options{DOPACKAGES}},GetPackages();
}
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 4140642b..ef924b67 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -383,10 +383,6 @@ sub filearray {
}
}
-sub getcontrol {
- return $ENV{DH_CONTROL} || 'debian/control';
-}
-
# Returns a list of packages in the control file.
# Must pass "arch" or "indep" or "same" to specify arch-dependant or
# -independant or same arch packages. If nothing is specified, returns all
@@ -405,8 +401,8 @@ sub GetPackages {
my $package="";
my $arch="";
my @list=();
- open (CONTROL, getcontrol()) ||
- error("cannot read ".getcontrol().": $!\n");
+ open (CONTROL, 'debian/control') ||
+ error("cannot read debian/control: $!\n");
while (<CONTROL>) {
chomp;
s/\s+$//;
diff --git a/debhelper.1 b/debhelper.1
index b27bfcfb..b5902d35 100644
--- a/debhelper.1
+++ b/debhelper.1
@@ -250,11 +250,6 @@ run. If you use DH_OPTIONS, be sure to use "dh_testversion 1.1.17" - older
debhelpers will ignore it and do things you don't want them to. One very
good way to set DH_OPTIONS is by using "Target-specific Variable Values" in
your debian/rules file. See the make documentation for details on doing this.
-.TP
-.I DH_CONTROL
-Use the filename contained in this environment variable instead of
-debian/control, for everything debhelper does that involves
-debian/control. If you need this, you know who you are.
.SH "SEE ALSO"
.TP
.BR /usr/share/doc/debhelper/examples/
diff --git a/debian/changelog b/debian/changelog
index 9fdbd42c..72d32c39 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.2.16) unstable; urgency=medium
+
+ * Bah, reverted that last change. It isn't useful because
+ dpkg-buildpackage reads the real control file and gets confused.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 28 Jan 2001 01:47:46 -0800
+
debhelper (2.2.15) unstable; urgency=medium
* Added the ability to make debhelper read a different file than
diff --git a/dh_gencontrol b/dh_gencontrol
index 0c03dfce..15e08203 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -19,9 +19,8 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
# Generate and install control file.
- doit("dpkg-gencontrol","-c".Debian::Debhelper::Dh_Lib::getcontrol(),
- "-l$changelog","-isp","-p$PACKAGE","-Tdebian/${EXT}substvars",
- "-P$TMP",@{$dh{U_PARAMS}});
+ doit("dpkg-gencontrol","-l$changelog","-isp","-p$PACKAGE",
+ "-Tdebian/${EXT}substvars","-P$TMP",@{$dh{U_PARAMS}});
# This chmod is only necessary if the user sets the umask to something odd.
doit("chmod","644","$TMP/DEBIAN/control");
diff --git a/dh_testdir b/dh_testdir
index 0bf917ae..394fa359 100755
--- a/dh_testdir
+++ b/dh_testdir
@@ -7,7 +7,7 @@
use Debian::Debhelper::Dh_Lib;
init();
-foreach $file (Debian::Debhelper::Dh_Lib::getcontrol(),@ARGV) {
+foreach $file ('debian/control', @ARGV) {
if (! -e $file) {
error("\"$file\" not found. Are you sure you are in the correct directory?");
}