summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installinfo2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a937bb6c..31dde712 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.0.97) unstable; urgency=low
+
+ * dh_installinfo: changed test to see if an info file is the head file to
+ just skip files that end in -\d+.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 11 May 2000 14:11:04 -0700
+
debhelper (2.0.96) unstable; urgency=low
* dh_installmodules: still add depmod -a calls if run on a package that
diff --git a/dh_installinfo b/dh_installinfo
index 3e642095..e00981ef 100755
--- a/dh_installinfo
+++ b/dh_installinfo
@@ -32,7 +32,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
foreach $file (@info) {
# Only register with install-info if this is a head file in
# a tree of info files.
- if ($file=~/\.info$/ && ! $dh{NOSCRIPTS}) {
+ if ($file !~ /-\d+$/ && ! $dh{NOSCRIPTS}) {
# Figure out what section this file goes in.
my $section='';
open (IN, "<$file") || die "$file: $!";