summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/postinst-gconf2
-rw-r--r--autoscripts/postinst-modules2
-rw-r--r--autoscripts/postrm-modules2
-rw-r--r--autoscripts/prerm-gconf2
-rw-r--r--debian/changelog7
5 files changed, 11 insertions, 4 deletions
diff --git a/autoscripts/postinst-gconf b/autoscripts/postinst-gconf
index f5e7b2bc..eec1d51c 100644
--- a/autoscripts/postinst-gconf
+++ b/autoscripts/postinst-gconf
@@ -1,3 +1,3 @@
if [ "$1" = "configure" ]; then
- /usr/sbin/gconf-schemas --register #SCHEMAS#
+ gconf-schemas --register #SCHEMAS#
fi
diff --git a/autoscripts/postinst-modules b/autoscripts/postinst-modules
index f2342da4..8d2c4cbc 100644
--- a/autoscripts/postinst-modules
+++ b/autoscripts/postinst-modules
@@ -1,3 +1,3 @@
-if [ "$1" = "configure" ] && [ -x /sbin/update-modules ]; then
+if [ "$1" = "configure" ] && [ -x "`which update-modules 2>/dev/null`" ]; then
update-modules >/dev/null || [ "$?" = 3 ]
fi
diff --git a/autoscripts/postrm-modules b/autoscripts/postrm-modules
index 45d65bea..35db8718 100644
--- a/autoscripts/postrm-modules
+++ b/autoscripts/postrm-modules
@@ -1,3 +1,3 @@
-if [ -x /sbin/update-modules ]; then
+if [ -x "`which update-modules 2>/dev/null`" ]; then
update-modules >/dev/null || [ "$?" = 3 ]
fi
diff --git a/autoscripts/prerm-gconf b/autoscripts/prerm-gconf
index 18e911ba..6a18816c 100644
--- a/autoscripts/prerm-gconf
+++ b/autoscripts/prerm-gconf
@@ -1,3 +1,3 @@
if [ "$1" = remove ] || [ "$1" = upgrade ]; then
- /usr/sbin/gconf-schemas --unregister #SCHEMAS#
+ gconf-schemas --unregister #SCHEMAS#
fi
diff --git a/debian/changelog b/debian/changelog
index 3f59698e..66f4af2a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.4) UNRELEASED; urgency=low
+
+ * Remove hardcoded pathc to update-modules and gconf-schemas in various
+ script fragments.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 8 Nov 2005 16:02:09 -0500
+
debhelper (5.0.3) unstable; urgency=low
* Remove dh_shlibs from binary-indep section of debian/rules.